On Tue, 26 Aug 2014, Tim Kientzle wrote:

On Aug 26, 2014, at 11:05 AM, Chris H <bsd-li...@bsdforge.com> wrote:

I'm currently testing 11. My build / install is from about 2 days ago.
I generally use xz compression, when creating archives. But when I
attempt the following:

tar -cvJ --options xz:9 -f ./archive-name.tar.xz ./file

it returns the following:

tar: Undefined option: `xz:9'

This has always worked in previous versions. Has the syntax changed,
and the man(1) pages just haven't caught up?

I can’t see any evidence in libarchive’s source that this ever worked.

The man page is a little confusing.  Here it says:

  --options options
      Select optional behaviors for particular modules.  The
      argument is a text string containing comma-separated
      keywords and values. These are passed to the modules that
      handle particular formats to control how those formats will
      behave.  Each option has one of the following forms:

              The key will be set to the specified value in every
              module that supports it.  Modules that do not
              support this key will ignore it.

Then below, after the last option, it says:

              Use type as compression method.  Supported values are
              store (uncompressed) and deflate (gzip algorithm).

      If a provided option is not supported by any module, that is a
      fatal error.

The first states that it is ignored, the latter states that it
is a fatal error.  The meaning of "any module" is subtle, at
least for my feeble brain ;-)

Also, the syntax for "[lr]zip:compression=type" is very clear,
whereas the syntax for compression-level keys omit the "=value".

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to