On 11/16/14 20:29, Steve Kargl wrote:
On Sun, Nov 16, 2014 at 08:16:36PM +0100, Hans Petter Selasky wrote:
On 11/16/14 20:03, Steve Kargl wrote:
On Sun, Nov 16, 2014 at 06:55:53PM +0000, Mark R V Murray wrote:


On 16 Nov 2014, at 18:51, Steve Kargl <s...@troutmask.apl.washington.edu> wrote:

If you have not read the entire thread, once the laptop keyboard and
video output lock up, I can ssh into the laptop.  If I run usbconfig,
it hangs, ^T tells me it is stuck in SX Lock, and the /dev/da0* devices
have not been destroyed.

Weirder and weirder :-(.

Something with SX locks? Hmm. I do use those for attach and detach for
RNG sources. Could it be that that stick of yours is somehow getting
involved in the RNG source locks?


It's not limited to a single usb device.  Plugging in/Unplugging
a logitech mouse dongle, the memstick, a Western Digital MY Passport
external usb hard drive, all lead to the locked keyboard and video.

I tried adding both RANDOM_DEBUG and USBDEBUG to the kernel, but the
mount of output is mind numbing.



Can you enter kgdb when the usbconfig is froozen, and backtrace all
kernel threads. You should see exactly what locks are the problem.

Maybe some lock didn't get properly unlocked!


I haven't tried kgdb.  I did try to attach gdb to the usbconfig
process via its pid, but gdb dumped core.

I haven't looked at locks in kgdb, what command or commands should
I try.



Hi,

You enter:

thread apply all bt

That will give you the backtrace of all threads. Grep for usbconfig, and figure out which line is causing the problem in the kernel. Then look at the USB explore threads and see where they are stuck in the detach of umass!

--HPS
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to