Hi,

Have been playing with this machine for a while now.
It is a quad core Pentium N3540 (ValleyView/Bay Trail), 8 GB RAM. It came
with a Broadcom WiFi card which I swapped for an Intel which is supported
by FreeBSD. Also swapped the hard drive for an SSD.

When first trying to boot FreeBSD with UEFI it would not boot.
It stops after the loader is trying to start the kernel.
My workaround now is using refind, http://www.rodsbooks.com/refind/
to set the screen resolution to 800x600. (Native is 1366x768)
Only then will it boot using UEFI.
I tried setting it to 1024x768, then it crashes. If it helps I can get the
backtrace.

The other "interresting" thing is that when UEFI-booting the
sdhci-controllers is not detected. (There are two, one card reader, and I
guess one for internal eMMC that is not present in this model).

Booting with legacy BIOS:
# pciconf -l| grep sdhci
sdhci_pci0@pci0:0:18:0: class=0x080501 card=0x09331025 chip=0x0f168086
rev=0x0e hdr=0x00
sdhci_pci1@pci0:0:23:0: class=0x080501 card=0x09331025 chip=0x0f508086
rev=0x0e hdr=0x00

Booting UEFI they are simply not there...


Also Xorg only works with BIOS. (Only VESA. I guess VESA drivers depends
on BIOS? For proper X support I guess I have to wait for the Haswell
drivers)

Jakob


_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to