On Tue, December 30, 2014 17:00, Nathan Whitehorn wrote:

> On 12/30/14 06:40, Jakob Alvermark wrote:
>> Hi,
>> Have been playing with this machine for a while now.
>> It is a quad core Pentium N3540 (ValleyView/Bay Trail), 8 GB RAM. It
>> came with a Broadcom WiFi card which I swapped for an Intel which is
>> supported by FreeBSD. Also swapped the hard drive for an SSD.
>> When first trying to boot FreeBSD with UEFI it would not boot.
>> It stops after the loader is trying to start the kernel.
>> My workaround now is using refind, http://www.rodsbooks.com/refind/
>> to set the screen resolution to 800x600. (Native is 1366x768) Only then
>> will it boot using UEFI. I tried setting it to 1024x768, then it
>> crashes. If it helps I can get the backtrace.
> [Not sure what's going on here]
>> The other "interresting" thing is that when UEFI-booting the
>> sdhci-controllers is not detected. (There are two, one card reader, and
>> I
>> guess one for internal eMMC that is not present in this model).
>> Booting with legacy BIOS:
>> # pciconf -l| grep sdhci
>> sdhci_pci0@pci0:0:18:0:      class=0x080501 card=0x09331025 chip=0x0f168086
>> rev=0x0e hdr=0x00 sdhci_pci1@pci0:0:23:0:    class=0x080501 card=0x09331025
>> chip=0x0f508086 rev=0x0e hdr=0x00
>> Booting UEFI they are simply not there...
> At least sometimes, the CSM is involved in initializing some peripherals
> (this happens with an isci(4) SAS controller I have, for example) and
> disabling it will result in them not appearing. This is a BIOS bug,
> unfortunately.
>> Also Xorg only works with BIOS. (Only VESA. I guess VESA drivers
>> depends on BIOS? For proper X support I guess I have to wait for the
>> Haswell
>> drivers)
> You can use xf86-video-scfb for a VESA-like experience on EFI systems.
> -Nathan

Didn't know that. I tried it and it works, but as I said above I have to
set the resolution to 800x600 to get it to boot, that's the resolution I
get in X.

Attached dmesg and the output of pciconf from both BIOS and UEFI booting.
I noticed that when booting UEFI I get:
real memory  = 10737418240 (10240 MB)
When it should be:
real memory  = 8589934592 (8192 MB)


Attachment: dmesg.bios
Description: Binary data

Attachment: dmesg.uefi
Description: Binary data

Attachment: pciconf.bios
Description: Binary data

Attachment: pciconf.uefi
Description: Binary data

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to