On a CURRENT system (FreeBSD 11.0-CURRENT #0 r280991: Thu Apr  2 19:01:05 CEST 
2015)
with most recent SVN tree revision of /usr/ports (Revision: 383115) I run into 
a very
nasty/sticky problem, which prevents updating/reinstalling/deleting port
textproc/clucene, see below.

I tried to reinstall/recompile sqlite and all requisite ports, but with no 
effect. I
maintain my ports in the traditional/flexible FreeBSD style by compiling them - 
not using
packages.

I also tried to use pkg to install the port in question, see this error beneath 
the error
when using portmaster:

"portmaster -da" / or "portmaster clucene"

[...]
===>>> Starting check for runtime dependencies
===>>> Gathering dependency list for textproc/clucene from ports
===>>> No dependencies for textproc/clucene

===>  Installing for clucene-2.3.3.4_6
===>   Registering installation for clucene-2.3.3.4_6
Installing clucene-2.3.3.4_6...
pkg-static: sqlite error while executing INSERT OR REPLACE INTO packages( 
origin, name,
version, comment, desc, message, arch, maintainer, www, prefix, flatsize, 
automatic,
licenselogic, mtree_id, time, manifestdigest)
VALUES( ?1, ?2, ?3, ?4, ?5, ?6, ?7, ?8, ?9, ?10, ?11, ?12, ?13, (SELECT id FROM 
mtree
WHERE content = ?14), NOW(), ?15) in file pkgdb.c:1602: FOREIGN KEY constraint 
failed ***
Error code 70

Stop.
make: stopped in /usr/ports/textproc/clucene


root: [ports] pkg install textproc/clucene
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
Checking integrity...Assertion failed: (strcmp(uid, p->uid) != 0), function
pkg_conflicts_check_local_path, file pkg_jobs_conflicts.c, line 360. Child 
process
pid=49420 terminated abnormally: Abort trap


Can somebody help?

Regards,

Oliver

Attachment: pgpeXAcbkpN8y.pgp
Description: OpenPGP digital signature

Reply via email to