On Apr 7, 2015, at 19:35, Konstantin Belousov <kostik...@gmail.com> wrote:

> On Tue, Apr 07, 2015 at 12:04:44PM -0700, Garrett Cooper wrote:
>> Hi,
>>      I just tried to upgrade my system from a Nehalem style era 
>> CPU/motherboard (a W series Xeon/P6T-WS) to a Haswell style CPU/motherboard 
>> (an E-series Haswell/Z97 motherboard), and I?ve run into some fun issues 
>> with my LSI 9240-4i controller. In particular, it?s timing out because of 
>> issues noted similar to here: 
>> https://lists.freebsd.org/pipermail/freebsd-stable/2011-October/064404.html 
>> . I?ve done the following so far to try and diagnose the issue:
>>      - Upgraded the firmware on the card and in the BIOS
>>      - Tweaked with the PCI-E settings (2.0/3.0; disabled power savings mode 
>> in the BIOS; etc)
>>      - Turned off 4GB ?remapping? on the PCM.
>>      - Booted USB key fob-based images running: 9.3-RELEASE, 10.1-RELEASE, 
>>      - Booted my original drive running 9.3-RELEASE
>>      - Booted with hw.mfi.msi=0 set in loader.
>>      - Booted with boot -v.
> One more thing to try, is to put the card into PCIe slot handled by the
> south bridge instead of the CPU slot.
> I have two Drake Skinnies card which I cannot use, since all my machines
> are desktop class, and the only available PCIe 8x+ slots are connected
> to CPU.  I was never able to get a satisfactory explanation why the
> thing does not like CPU' PCIe.

Northbridge, Southbridge, didn’t seem to matter :/… I’ve tried all 3 PCI-E 
slots to no avail.

One thing that I’m thinking might be a problem is the fact that it’s sharing 
resources between the onboard graphics and the storage controller, and plus the 
other two slots were supposedly dedicated for storage purposes or some such 
(NVME, etc).

Guess I’ll try neutering the onboard GPU and see what happens...

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

Reply via email to