On Thursday, August 13, 2015 08:21:44 AM Thomas Mueller wrote:
> > T> Thinking I might have used the wrong syntax with ifconfig, I tried again 
> > with rsu0 instead of ndis0 or other failed attempts, and was successful 
> > connecting to Internet.
> > AFAIU, if you got rsu(4) driver in your kernel it will attach to the 
> > hardware,
> > and the ndis(4) driver won't be able to.
> > Have you tried to used ndis(4) before on an unpatched vanilla FreeBSD?
> > Totus tuus, Glebius.
> I have tried to use ndis before, but never successfully.  I used custom 
> kernel, but src tree was not patched.
> Do I have to build a separate kernel without rsu to test ndis, or is 
> disabling at loader good enough?
> set hint.rsu.0.disabled="1"

This isn't sufficient.  This leaves the device named rsu0 but disables it 
letting other drivers attach to it.  You need to remove the rsu driver entirely
or use devctl to force the driver to ndis.

John Baldwin
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to