03.11.2015 23:50, Maxim Pugachev пишет:

> I tried to install r29273 into Parallels VM, but got an error on
> "distextract" stage. Here is the last messages from bsdinstall_log:
> DEBUG: f_debug_init: ARGV=[distextract] GETOPTS_STDARGS=[dD:]
> DEBUG: f_debug_init: debug=[1] debugFile=[/tmp/bsdinstall_log]
> DEBUG: Running installation step: distextract
> Killed
> Last message from /var/log/messages:
> Nov  3 20:02:9  kernel: pid 967 (distextract), uid 0, was killed: out
> of swap space
> My VM has 2 gigs of memory, vmstat tells that I have ~537M free
> (swapinfo tells nothing). I dunno is it a bug or I'm doing something
> wrong.

I've also come across with this recently.

Don't remember all the details, something like this:
. install CURRENT to bhyve using 1G memory, get out of swap error;
. set 2G memory, got the same error, didn't try more memory (seemed
  not sane to).

Took a look at the boot environment and found out that something was
wrong (with the filesystem). Unfortunately, I do not recall now what
was it. :-( Something like too small /tmp, no /tmp at all, something

But definitely the error message was misleading and not the case of
the failure.

WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to