On 24 January 2016 at 11:36, Otacílio <otacilio.n...@bsd.com.br> wrote:

> Em 24/01/2016 07:24, Olivier Cochard-Labbé escreveu:
>
>> On Sun, Jan 24, 2016 at 9:41 AM, Ben Woods <woods...@gmail.com> wrote:
>>
>> Hi everyone,
>>>
>>> Could someone running FreeBSD current on a test machine try loading the
>>> ip_mroute driver on their machine?
>>>
>>> ​Hi,
>>
>> no problem here:
>>
>> root@lame5 # uname -a
>> FreeBSD lame5.bsdrp.net 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r294522: Thu
>> Jan 21 20:07:04 CET 2016
>> r...@lame5.bsdrp.net:/usr/obj/usr/src/sys/GENERIC-NODEBUG
>>   amd64
>> root@lame5 # kldload ip_mroute
>> root@lame5
>> ​
>> # kldstat -m ip_mroute
>> Id  Refs Name
>> 497    1 ip_mroute
>>
>>
>> ​Regards,
>>
>> Olivier​
>>
>>
> No problem here also.
>
> root@nostromo:~ # kldload ip_mroute
> root@nostromo:~ # kldstat
> Id Refs Address            Size     Name
>  1   34 0xffffffff80200000 1e39ca8  kernel
>  2    1 0xffffffff8203b000 e3b8     cuse.ko
>  3    1 0xffffffff8204a000 3d90     pty.ko
>  4    1 0xffffffff82221000 57b8     fdescfs.ko
>  5    1 0xffffffff82227000 a3ac     linprocfs.ko
>  6    1 0xffffffff82232000 695a     linux_common.ko
>  7    1 0xffffffff82239000 26f8a    vboxguest.ko
>  8    1 0xffffffff82260000 7a9      vboxvideo.ko
>  9    1 0xffffffff82261000 52092    drm2.ko
> 10    1 0xffffffff822b4000 2679     iicbus.ko
> 11    1 0xffffffff822b7000 1f6a     imgact_binmisc.ko
> 12    1 0xffffffff822b9000 657f     nullfs.ko
> 13    1 0xffffffff822c0000 abe8     tmpfs.ko
> 14    1 0xffffffff822cb000 ceff     ip_mroute.ko
> root@nostromo:~ # uname -a
> FreeBSD nostromo 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r294319M: Tue Jan 19
> 20:29:21 BRT 2016 ota@nostromo:/usr/obj/usr/src/sys/GENERIC  amd64
>


Thanks for your feedback everyone. Having spent some time now
investigating, I have confirmed that this problem is related to VIMAGE.

With VIMAGE enabled in the kernel, loading the ip_mroute kernel module will
fail.

With VIMAGE disabled on the same kernel source (no other changes), loading
the ip_mroute kernel module works fine.

I have submitted this bug report:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206583

Regards,
Ben

--
From: Benjamin Woods
woods...@gmail.com
_______________________________________________
freebsd-current@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to