On 30/04/2016 06:53 PM, Graham Menhennitt wrote:
> Hi all,
> I have a USB disk that I use for backup. Up till now, it's mounted
> without any problems at boot time. After updating to -current as of
> yesterday, it doesn't mount and causes the boot to fail.
> My /etc/fstab looks like:
>     # Device    Mountpoint    FStype    Options    Dump    Pass#
>     /dev/ada0s1a    /        ufs    rw    1    1
>     /dev/ada0s1b    none        swap    sw    0    0
>     /dev/da0a    /backup        ufs    rw,late    1    1
> I tried adding the "late" to fix the problem, but it doesn't help.
> The error message is:
>     /dev/ada0s1a: clean...
>     Can't stat /dev/da0a: No such file or directory
>     Unknown error; help!
>     ERROR: ABORTING BOOT (sending SIGTERM to parent)!
> (hand transcribed - maybe typos)
> Can anybody help, please.
> Thanks,
>     Graham
>Sorry, I forgot to mention...
>I commented out that line from fstab which allows the boot to complete.
>I can then manually mount it without any problems. It looks like the
>device doesn't get created early enough.

I had the same error message with a USB storage drive, so I used 
kern.cam.boot_delay="10000" in /boot/loader.conf with success.
My /etc/fstab is /dev/da1p1      /mnt/usb1       ufs     rw      2       2
Have a look at /boot/defaults/loader.conf under Kernel tunables.


freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to