On 05/09/16 18:10, Hans Petter Selasky wrote:
On 05/09/16 04:34, Sergey Manucharian wrote:
I'm running FreeBSD 11.0-CURRENT r292595 on ThinkPad T430 (i7-3520M,
Intel video 4000). Today I tried to update to a fresher version.
Something has been broken somewhere between r296485 and r297692,
I suspect namely i915kms - it won't boot: at the boot screen I see that
all modules are loaded, then after "Booting..." message at the bottom
screen turns black in 1-2 seconds of booting process, it seems to be the
point when it regularly switches to native resolution.

Can somebody shed light on it? What can I check to get more info on

Regularly I update to the revisions used to build snapshots at:


assuming that those revisions have less issues. So tried a few, including
the head. None worked for me after a certain revision (from the range I
mentioned above).

Thanks for advices!


I'm seeing the same thing with a MacBookPro. When loading drm2 and i915
after boot, it works. I think it is something simple causing this failure.



Can you try the attached patch. Works for me.


diff --git a/sys/dev/drm2/i915/intel_drv.h b/sys/dev/drm2/i915/intel_drv.h
index fd5817f..d9b01b8 100644
--- a/sys/dev/drm2/i915/intel_drv.h
+++ b/sys/dev/drm2/i915/intel_drv.h
@@ -50,6 +50,8 @@
 			pause((WMSG), 1);				\
 		else							\
 			DELAY(1000);					\
+		if (cold)						\
+			end -= howmany(hz, 1000);			\
 	}								\
 	ret;								\
@@ -68,6 +70,8 @@
 		} else {						\
 			DELAY(1000);					\
 		}							\
+		if (cold)						\
+			timeout__ -= howmany(hz, 1000);			\
 	}								\
 	ret__;								\
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to