It's probably the switch to WITH_SYSTEM_COMPILER, which is confusing the
logic to think a newer external compiler is being used.  This problem
will likely creep up on any platform using GCC 4.2 in base that meets

Try this patch please:

On 6/28/2016 12:43 PM, Jukka Ukkonen wrote:
> The last version I tried was current pulled from svn today
> only a few hours ago. I guess around 16:00 GMT today is
> the best estimate I can give right now. The system on
> which I did the test is already powered down. I can check
> the exact svn release number tomorrow, though.
> The latest successful rebuild I have done was on the 19th.
> After that I tried a new rebuild only yesterday morning, and
> then it suddenly failed.
> --jau
>> On 28 Jun 2016, at 21:14, Justin Hibbits <> wrote:
>>> On Tue, Jun 28, 2016 at 12:34 PM, Jukka A. Ukkonen <> wrote:
>>> Hello all,
>>> It seems there is yet another compiler dependent problem on
>>> ppc64. Most likely the same problem applies to all platforms
>>> using the old gcc as the default compiler.
>>> When trying to build gnu/lib/libstdc++ the compiler seems to
>>> get the option -std=c++11. The gcc complains about this and
>>> the build gets invariably broken at that point. This has now
>>> been going on for two days or so. This makes me believe nobody
>>> is actively running rebuilds of the latest current on any gcc
>>> based platform.
>>> --jau
>> Which revision are you using?  This should've been fixed a couple
>> weeks ago.  Adding Bryan Drewery, who made the fix.
>> - Justin

Bryan Drewery

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to