On 8/1/2016 12:40 PM, Randy Westlund wrote:
On Mon, Aug 01, 2016 at 11:05:54AM +0200, O. Hartmann wrote:
On every(!) USB drive which worked well with 11-CURRENT up to 11-BETA, I fail
to access with 12-CURRENT (12.0-CURRENT FreeBSD 12.0-CURRENT #14 r303475: Fri
Jul 29 11:59:11 CEST 2016) with the error shown below.

On USB flash drives I created myself, the suggested gpart command solved the
problem, but I can not do this with drives I was given by a vendor or supplier.

What is wrong?

Kind regards and thank you very much in advance,

O. Hartmann

On console, I get the report:

GEOM_PART: da4 was automatically resized.
  Use `gpart commit da4` to save changes or `gpart undo da4` to revert them.

I noticed something similar when I was trying to dd a more recent
memstick installer to a USB drive on 12-CURRENT.  When I plugged in the
flash drive I couldn't dd to it until I noticed that message in syslog
and ran 'gpart undo da0'.  Looks like something is unhelpfully
auto-resizing partitions.

Do you have growfs_enable in your rc.conf file? I think this is added to certain flash images by default so it will automatically grow to your device capacity. See ...


... and ...


freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to