I've just installed FreeBSD 11 on Soekris net5501 with the following wifi

root@soekris:~ # dmesg |grep ath0
ath0: <Atheros 5413> mem 0xa0010000-0xa001ffff irq 15 at device 17.0 on pci0
ath0: AR5413 mac 10.5 RF5413 phy 6.1
ath0: 2GHz radio: 0x0000; 5GHz radio: 0x0063

ath0@pci0:0:17:0:       class=0x020000 card=0x110719b6 chip=0x001b168c
rev=0x01 hdr=0x00
    vendor     = 'Qualcomm Atheros'
    device     = 'AR5413/AR5414 Wireless Network Adapter [AR5006X(S)
    class      = network
    subclass   = ethernet

But wat is very strange for me is that I do not see ath0 device on ifconfig:

root@soekris:~ # ifconfig ath0
ifconfig: interface ath0 does not exist

At the same time if I crate wlan0 to list caps it works:

root@soekris:~ # ifconfig wlan0 create wlandev ath0
root@soekris:~ # ifconfig wlan0 list caps

root@soekris:~ #

The issues is that when I try to start wlan0 in hostap mode - FreeBSD
freezes, unfortunatelly I cannot find my serial port cable atm and cannot
see what exactly is displayed on the console but it's a hard freeze and the
device do not reboot after it e.g. power cycle is required.

When configured from rc.conf it boots and do not freeze but still says
status: no carrier and hostapd complains that the device is not configured.

snippet from rc.conf:

create_args_wlan0="wlanmod hostap"
ifconfig_wlan0="ssid cheffo country bg up"
ifconfig_bridge0="addm vr0 addm vr1 addm vr2 addm vr3 addm wlan0 up"
ifconfig_bridge0_alias0="inet netmask"

I'm still with GENERIC kernel and there are no changes or custom cpu
optimizations done so far:

root@soekris:~ # uname -a
FreeBSD 11.0-BETA3 FreeBSD 11.0-BETA3 #0
r303469: Fri Jul 29 04:28:58 UTC 2016

root@soekris:~ # cat /boot/loader.conf

root@soekris:~ # kldstat
Id Refs Address    Size     Name
 1   19 0xc0400000 1a9313c  kernel
 2    1 0xc1e95000 80d4     geom_label.ko
 3    1 0xc1e9e000 bc80     if_bridge.ko
 4    2 0xc1eaa000 6ce0     bridgestp.ko
 5    1 0xc1eb1000 3a70     dcons.ko
 6    1 0xc1eb5000 5978     cryptodev.ko
 7    1 0xc1ebb000 548c     glxsb.ko
 8    1 0xc1ec1000 1d6c     wlan_xauth.ko

I have to mention that I've tried with 11-BETA2 first and there were the
same behaviour, and also I have used this soekris setup for few years with
FreeBSD 7 and 8 for a home wifi router so I do know that the hardware is
supported and OK, as it worked rock solid just before reinstalling it with
FreeBSD 11.

Any advice on how to get wifi working again?

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to