On Sat, August 20, 2016 22:54, Dimitry Andric wrote:
> On 21 Aug 2016, at 03:07, Nenhum_de_Nos <math...@eternamente.info> wrote:
>> I tried to build 11.0-RC1 from two machines here, my home server and a
>> vm I installed and updated to 10.2 just to test for the real deal on
>> that server. Both failed on the same spot:
> ...
>> 3.      Running pass 'Function Pass Manager' on module
>> '/usr/src-11.0/lib/clang/libclangcodegen/../../../contrib/llvm/tools/clang/lib/CodeGen/CGBlocks.cpp'.
>> 4.      Running pass 'X86 DAG->DAG Instruction Selection' on function
>> '@_ZN5clang7CodeGen15CodeGenFunction12EmitCallArgsINS_17FunctionProtoTypeEEEvRNS0_11CallArgListEPKT_N4llvm14iterator_rangeINS_4Stmt17ConstExprIteratorEEEPKNS_12FunctionDeclEj'
>> c++: error: unable to execute command: Segmentation fault (core dumped)
> If you are using 10.2-RELEASE, you will not have this fix, which most
> likely solves the crash you are seeing:
> https://svnweb.freebsd.org/changeset/base/286033
> Please try to apply this to your 10.2 source tree, recompile clang, and
> then try to build 11.0 again.
> Alternatively, first upgrade to the latest stable/10, which should also
> fix it.  This costs more time, but is easier to execute.
> -Dimitry


I updated to 10.3 then the build process got past that issue.

Problem solved.

thanks again,


"We will call you Cygnus,
the God of balance you shall be."

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to