Source upgrade from r306307 to r306337 completed OK; this was on build
machine (laptop is "Installing everything" as I type).  Serial console
(on panicked build machine) reads:

Setting hostname:
Setting up harvesting: 
Feeding entropy: .
Starting Network: lo0 re0.
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCubt0 on uhub0
ubt0: <Broadcom Corp BCM43142A0, rev 2.00/1.12, addr 3> on usbus0
SUM_IPV6,TXCSUM_random: harvesting attach, 8 bytes (4 bits) from ubt0
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
        inet WARNING: attempt to domain_add(bluetooth) after 
netmask 0xff0000WARNING: attempt to domain_add(netgraph) after domainfinalize()
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        groups: lo 
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
Duplicate free of 0xfffff8000ef61500 from zone 0xfffff8000772b000(mbuf) slab 

cpuid = 2
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe085dc95700
vpanic() at vpanic+0x182/frame 0xfffffe085dc95780
panic() at panic+0x43/frame 0xfffffe085dc957e0
uma_dbg_free() at uma_dbg_free+0xee/frame 0xfffffe085dc95810
uma_zfree_arg() at uma_zfree_arg+0x64/frame 0xfffffe085dc95860
m_freem() at m_freem+0x90/frame 0xfffffe085dc95880
sendit() at sendit+0x1c8/frame 0xfffffe085dc958d0
sys_sendmsg() at sys_sendmsg+0x61/frame 0xfffffe085dc95930
amd64_syscall() at amd64_syscall+0x314/frame 0xfffffe085dc95ab0
Xfast_syscall() at Xfast_syscall+0xfb/frame 0xfffffe085dc95ab0
--- syscall (28, FreeBSD ELF64, sys_sendmsg), rip = 0x8009672ba, rsp = 
0x7fffffffe588, rbp = 0x7fffffffe690 ---
KDB: enter: panic
[ thread pid 526 tid 100120 ]
Stopped at      kdb_enter+0x3b: movq    $0,kdb_why

I can leave the machine in this state & perform "directed pokes" at it,
given appropriate clues.

I'm about to try rebooting laptop (just finished similar upgrade);
I'll report back whether it behaves similarly or not, but I don't
expect to be able to leave it panicked (as I use it to access
everything else ).


Eh; I decided to defer sending this until I tried the laptop: it
had a similar panic, just after starting powerd.  On the laptop,
when it's running stable/11, the next things to pop up are the
startup messages for hald (which the build machine does not have)
and then sshd (which each machine runs).

The build machine runs a GENERIC kernel; laptop runs a slightly-customized
kernel (includes GENERIC & tweaks from there).

I tried "panic" at the laptop's "db> " prompt, but I have no crash dump.

David H. Wolfskill                    
Those who would murder in the name of God or prophet are blasphemous cowards.

See for my public key.

Attachment: signature.asc
Description: PGP signature

Reply via email to