[A version of the below has been submitted to bugzilla as 214598. The specific 
powerpc64 context is a PowerMac11,3 PowerMac G5 "Quad Core" --actually 2 
sockets with each having 2 cores.]

The failure was: "panic: vm_fault: fault on nofault entry, addr: 

Details. . .

I manually entered ddb and gave it the dump command. 2 of 3 chunks worked. This 
is new since last I tried (long ago): it used to be it complained about the DMA 
request size being too large. (I've not tried in a long time, under some 10.<?> 
.) So this got a lot farther than I've ever seen before for this type of 

Transcribed from a camera picture of the screen. . . (Typos?)
(Also: I will drop off various leading zeros and some formatting will be 

KDB: enter: manual escape to debugger
[ thread pid 12 tid 10018 ]
Stopped at       .kdb_enter+0x70:       ori r0, r0, 0x0
db> dump
Dumping 9 MB (3 chunks)
  chunk 0: 10MB (2510 pages) ... ok
  chunk 1: 1MB (24 pages) ... ok
  chunk 2: 1MB (2 pages)panic: vm_fault: fault on nofault entry, addr: 
cpuid = 1
KDB: stack backtrace:
0xf93cd0: at .kdb_backtrace+0x6c
0xf93df0: at .vpanic+0x178
0xf93eb0: at .panic+0x34
0xf93f30: at .vm_fault_hold+0x1ac
0xf94120: at .vm_fault+0x98
0xf941c0: at .trap_pfault+0xe8
0xf94240: at .trap+0x1e44
0xf944b0: at .powerpc_interrupt+0x1e0
0xf94550: kernel DSI read trap 0 0xc000000000022ff8
          by .memcpy+0x144:
          r1  =  0xf94800
          cr  =0x40000424
          xer =0x20000000
          ctr =     0x200
          r2  = 0x10de000
          sr  =0x40000000
0xf94800: at .moea64_kextract+0x124
0xf94840: at tmpstk+0x297c
0xf948c0: at ._bus_dmamap_sync+0x124
0xf94960: at .ata_dmaload+0x1e8
0xf94a00: at .ata_begin_transaction+0x240
0xf94aa0: at .ataaction+0x4e0
0xf94b50: at .xpt_run_devq+0x934
0xf94c40: at .xpt_action_default+0x3a8
0xf94cf0: at .ata_action+0x3c8
0xf94d80: at .xpt_actino+0x44
0xf94e00: at .xpt_polled_action+0x60c
0xf94ec0: at .adadump+0x33c
0xf954e0: at .dump_write+0x88
0xf954e0: at .dump_sys_cb_dumpdata+0x124
0xf955c0: at .dumpsys_foreach_chunk+0x68
0xf95660: at .dumpsys_generic+0x26c
0xf95770: at .doadump+0xbc
0xf95800: at .db_dump+0x44
0xf95880: at .db_command+0x3f4

(I omit the rest going back to "0xc0000000b6b4f920: at blocked_loop+0x38".)

Mark Millard
markmi at dsl-only.net

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to