On 12/16/2016 16:20, John Baldwin wrote:
> On Thursday, December 15, 2016 03:57:58 PM Adrian Chadd wrote:
>> heh, an updated BIOS that solves the problem will solve the problem. :)
>> I think you have enough information to provide to supermicro. Ie,
>> "SMAP says X, when physical memory pages at addresses X are accessed,
>> they don't behave like memory, maybe something is wrong".
>> All I can think of is some hack to add a blacklist for that region so
>> you can boot the unit. But it makes me wonder what else is going on.
> We have the blacklist: it is the memory test.  That is the way to workaround
> this type of BIOS breakage.  This is just the first time in over a decade that
> test has been relevant.

I've got a SuperMicro X10SRA board that I bought back in March, I think.
It was run CURRENT fine since then, until last month, when it started
hanging during boot. I was about to update it to a new version of
CURRENT when it started hanging at boot, but hadn't updated yet. The
hang is after (verbose boot):

Package ID shift: 4
L3 cache ID shift: 4
L2 cache ID shift: 1
L1 cache ID shift: 1
Core ID shift: 1

Recently I've tried booting 9.3 and 10.3 on it without success. Other
operating systems boot fine. Thinking the hang was similar to the one in
this thread (or at least the board is), I tried many different BIOS
changes and also tried enabling the memory test, but none of that
changes anything. This is a single socket board so there are no NUMA or
memory interleaving options in the BIOS. The BIOS is up to date (2.0a).
It will boot if SMP is disabled. That's obviously sub-optimal, but is
useful for building updated kernels, which I've tried. If anyone has any
suggestions or ideas, I'd appreciate it.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to