On Sat, 31 Dec 2016 13:11:50 +0100, Ronald Klop <ronald-li...@klop.ws> wrote:


I just rebuild kernel+world (with NO_CLEAN=yes). Installworld failed:
===> libexec/rtld-elf (install)
chflags -h noschg /usr/libexec/ld-elf.so.1
install -s -o root -g wheel -m 555 -C -b -fschg -S ld-elf.so.1 /libexec/ld-elf
install -o root -g wheel -m 444 ld-elf.so.1.debug /usr/lib/debug/libexec/ld-el
install  -o root -g wheel -m 444 rtld.1.gz  /usr/share/man/man1/
rm -f /usr/share/man/man1/ld-elf.so.1.1 /usr/share/man/man1/ld-elf.so.1.1.gz; i nstall -l h /usr/share/man/man1/rtld.1.gz /usr/share/man/man1/ld-elf.so.1.1.gz
*** Signal 11

make[5]: stopped in /usr/src/libexec/rtld-elf
*** Error code 1

No every command I run segmentation faults.
Can I recover this?

I run 12-CURRENT/amd64 and just svn upped an hour ago. I'll try to use /rescue to copy ld-elf.so.1 from a snapshot.


This worked. Pffff. :-)
# /rescue/cp /libexec/ld-elf.so.1 /var/tmp/

# /rescue/cp /.zfs/snapshot/auto-2016-12-30_20.00.hourly/libexec/ld-elf.so.1 /libexec/
cp: /libexec/ld-elf.so.1: Operation not permitted

# /rescue/chflags -h noschg /libexec/ld-elf.so.1

# /rescue/cp /.zfs/snapshot/auto-2016-12-30_20.00.hourly/libexec/ld-elf.so.1 /libexec/

I will try a clean build now. This will take hours and hours on my laptop compiling clang, so I'll see in the new year if others experience the same ld-elf problem before I installworld again.

Regards and happy new year,
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to