[Note: I experiment with clang based powerpc64 builds,
reporting problems that I find. Justin is familiar
with this, as is Nathan.]

I tried to update the PowerMac G5 (a so-called "Quad Core")
that I have access to from head -r312761 to -r313864 and
ended up with random panics and hang ups in fairly short
order after booting.

Some approximate bisecting for the kernel lead to:
(sometimes getting part way into a buildkernel attempt
for a different version before a failure happens)

-r313266: works (just before use of atomic_fcmpset)
-r313271: fails (last of the "use atomic_fcmpset" check-ins)

(I did not try -r313268 through -r313270 as the use was
gradually added.)

So I'm currently running a -r313864 world with a -r313266

No kernel that I tried that was from before -r313266 had the

Any kernel that I tried that was from after -r313271 had the

Of course I did not try them all in other direction. :)

Mark Millard
markmi at dsl-only.net

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to