On Tue, 21 Mar 2017 00:09:06 +0200 Toomas Soome <tso...@me.com> wrote

> > On 20. märts 2017, at 23:58, Chris H <bsd-li...@bsdforge.com> wrote:
> > 
> > I'm attempting to get a video card that DTRT on FreeBSD.
> > I started with the graphics provided by an AMD A6-7470K,
> > only to discover it's not yet supported. So I forked out
> > for a recent nvidia card, and build/installed a new
> > world/kernel.
> > Everything seemed to be as one would expect, except there
> > was an issue with loader.efi. So I had to move mine aside,
> > and use the one off the install media (tho I understand
> > the (u)efi has since been fixed). Now, I'm attempting to
> > obtain textmode. The text stripped from a tty, and pasted
> > to a new file in a textmode editor -- ee(1) for example;
> > pads the line with spaces to EOL, and prefaces each line
> > following the first line with rubbish (about 1 to 2
> > characters worth).
> > So "graphics mode" or vt(4) isn't going to get it, for me.
> > Textmode, and syscons(4) has always worked as expected, and
> > I thought I'd try to re-enable it, or get textmode via vt(4).
> > But all attempts fail.
> > excerpt from my KERNCONF
> > 
> > device        vga
> > options     VESA
> > 
> > device        sc
> > options     SC_PIXEL_MODE
> > 
> > device        vt
> > device        vt_vga
> > device        vt_efifb
> > 
> > However, following the advice on the freebsd wiki, querying
> > the value in sysctl(8) returns:
> > # sysctl hw.vga.textmode
> > sysctl: unknown oid 'hw.vga.textmode'
> > 
> > OK how bout vidcontrol(1)
> > # vidcontrol -i adapter
> > vidcontrol: obtaining adapter information: Inappropriate ioctl for device
> > 
> > So, it appears from my standpoint that textmode is no longer
> > supported?
> > 
> > FWIW:
> > FreeBSD trump.whitehouse.gov.test 12.0-CURRENT FreeBSD 12.0-CURRENT #0
> > r314700: Sun Mar 5 09:01:30 PST 2017
> > r...@trump.whitehouse.gov.test:/usr/obj/usr/src/sys/TESTKERN amd6
> > 
> > Thank you for anything that might help me obtain textmode again.
> > 
> > -
> 
> The problem with UEFI is that the fact if you can only get “text” aka VGA
> text mode if your card happens to have the proper firmware and you can set up
> the card… UEFI as such does only provide framebuffer based console, and
> that framebuffer is either linear memory mapped or pure software - in last
> case only KMS console framebuffer will do any good. 
Thanks for the reply, Toomas.
I'm running the nvidia blob from the ports tree, version 375.26_1.
Am I to understand it doesn't support textmode through (u)efi?
All my other boxes also use the nvidia blob, and provide textmode,
along with sc/syscons(4) support. But I'm not booting (u)efi on them
either. So I guess (u)efi / vt(4) are to blame? My card is pretty
recent. I'd think that it would support all the bells, and whistles.
But then again... ;-)
Oh well, I guess I don't have to use (u)efi.

Thanks again, Toomas!

--Chris
>
> rgds,
> toomas
> 
> _______________________________________________
> freebsd-current@freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"


_______________________________________________
freebsd-current@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to