On Tue, 21 Mar 2017 10:15:35 +0100
Mathieu Arnold <m...@freebsd.org> wrote:

> Le 21/03/2017 __ 06:22, Chris H a __crit :
> > On Tue, 21 Mar 2017 13:14:56 +0800 Kevin Lo <ke...@freebsd.org> wrote
> >  
> >> On Mon, Mar 20, 2017 at 09:11:44PM -0700, Chris H wrote:  
> >>> On Mon, 20 Mar 2017 20:56:05 -0700 "Chris H" <bsd-li...@bsdforge.com> 
> >>> wrote
> >>>  
> >>>> I'm not sure which of the two lists I'm directing
> >>>> this to is the best/correct one. So I picked both.
> >>>>
> >>>> To the point; I received this message during a big
> >>>> build session. I was only able to catch the one from
> >>>> x11/nvidia-driver in such a way as to actually get
> >>>> the entire message:
> >>>>
> >>>> Installing nvidia-driver-375.26_1...
> >>>> ELF binary type "3" not known.
> >>>> /bin/sh: /compat/linux/sbin/ldconfig: Exec format error
> >>>>
> >>>> I built && installed emulators/linux_base-c7 *prior*
> >>>> to installing this. This is on a:
> >>>>
> >>>> FreeBSD 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r314700:
> >>>> Sun Mar 5 09:01:30 PST 2017 amd64  
> >>> Sorry. Forgot to add the ports revision.
> >>>
> >>> revision 435383  
> >> Did you do kldload linux64 ?  
> > Thanks for the reply, Kevin.
> > Yes. Both before building/installing nvidia-driver,
> > and via loader.conf(5):
> >
> > linux_load="YES"
> > nvidia-modeset_load="YES"
> >  
> 
> So your answer is not "Yes" but "No", you don't have linux64, you need
> linux64_load=yes too.
> 

Or remove the option for Linux support (make config).  I've never
used it myself and have no idea what benefits it's supposed to
provide.

That would eliminate your Linux problems re nvidia-driver.

-- 
Gary Jennejohn
_______________________________________________
freebsd-current@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to