On Mon, 26 Jun 2017 13:26:08 +0200
Gary Jennejohn <gljennj...@gmail.com> wrote:

> On Mon, 26 Jun 2017 10:29:47 +0200
> "O. Hartmann" <o.hartm...@walstatt.org> wrote:
> > Over the past week we did not update several 12-CURRENT running development
> > hosts, so today is the first day of performing this task.
> > 
> > First I hit the very same problem David Wolfskill reported earlier, a fatal
> > trap 12, but fowllowing the thread, I did as advised: removing /usr/obj
> > completely (we use filemon/WITH_META_MODE=YES all over the place) and
> > recompiling world and kernel.
> > 
> > Since tag 20170617 in /usr/src/UPDATING referred to the INO64 update and the
> > INO64 update hasn't performed so far starting from r319971, I installed the
> > kernel, rebooted the box in single user mode (this time smoothly), did a
> > mergemaster and tried to do "make installworld" - but the box instantanously
> > bails out:
> > 
> > [...]
> > Fatal error 'Cannot allocate red zone for initial thread' at line 392 in
> > file /usr/src/lib/libthread/thr_init.c
> > pid 60 (cc) uid0: exited on signal 6 ...
> > 
> > [...]
> > 
> > That way, I obviously can not install a world :-(
> > 
> > What is wrong here? Is the problem resovable?
> >   
> How recent was your last update?  Some changes were made just a few
> hours ago to fix a stack growth problem in threads.

Well, what do you mean by "... source is not up to date ..."? Performing an svn
update of /usr/src should suffice, shouldn't it? If not, then ... please
correct me. I think the sources are up to date as of the moment the bug occured.

I consider the sources up to date, it is on the latest updated box r320355.

There are so far two variations: one is r319971 -> 320351 as the subject
indicates, the second box is r320144 -> 320355.

> Either your source is not up to date, or a new bug was introduced by
> the intended fix.

As described earlier, I ran into a coredump by not having built world and
kernel from scratch but with filemon. That was r320251. Cleaning
(deleting) /usr/obj/* and rebuilding world and kernel and performing the update
of the system as required (install the new kernel, boot the new kernel in
single user mode) succeeded, but installworld then failed.
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to