On Tuesday, August 01, 2017 09:47:41 AM Andriy Gapon wrote:
> On 01/08/2017 02:31, Ngie Cooper wrote:
> > Hi,
> >     I tried upgrading my host from 11.1-STABLE to 12.0-CURRENT, and it 
> > didn’t work because abd_is_linear is an undefined symbol (it exists in 
> > sys/conf/files, but not sys/modules/zfs/Makefile). I tried adding abd.c to 
> > sys/modules/zfs/Makefile and it didn’t immediately fix my compilation 
> > problem (ran into a linker error instead).
> >     If it isn’t fixed in the next few hours I’ll try my hand at fixing the 
> > problem.
> I am not sure what exact problem you have...
> abd.c should be added to the list of source files via
> .include "${SUNW}/uts/common/Makefile.files"
> Perhaps something to do with "inline"...

Oh, yes.  If you use -fno-inline-funcs or the like.  I forgot to
send this to Andriy earlier, but here is the fix I'm using:


John Baldwin
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to