On Tue, Aug 22, 2017 at 04:19:58PM +0300, Konstantin Belousov wrote:
> ...
> > > Ok, can you rebuild kernel and libc from scratch ?  I.e. remove your
> > > object directories.
> > 
> > I think I'll need a working /bin/sh to do that.  As noted, I could
> > try the stable/11 /bin/sh; on the other hand, if it's dying in a
> > library, that's not likely to help a whole lot. :-}
> I highly suspect that this is not /bin/sh at all.  Backtrace strongly
> suggests that the malloc() has issues, but again I suspect that the
> reason is not an issue in malloc, but its use of TLS.

I think I hope that this use of "TLS" is not the one associated with
(say) SSL....  :-}

> The amd64 changes were to the TLS base register handling.  So you might
> try to boot previous kernel.  If this works out without replacing libc
> then it is definitely TLS, but I still do not know what is wrong.
> ....

OK; we have a bit of progress, then:
* When I tried to rename the kernel directories in /boot, I got more
  segfaults.  So I figured I'd use the boot menu to select kernel.old, and
  just tried "sudo shutdown -r now" -- and got a segfault.  "sudo reboot"
  did, as well.  So did "sudo kill 1".  On a whim, I tried "sudo halt";
  that actually worked.

* After the (successful) reboot from kernel.old, I was able to rename
  kernel directories without issue.  This may be useflu evidence.

* Flushed with that success, I have started a fresh clean build of
  r322776.  (I had managed to clear /usr/obj prior to the reboot.)

* I should be able to provide updated status within about 30 minutes.

Thanks again for all your help!

David H. Wolfskill                              da...@catwhisker.org
If we wish to eliminate sources of Fake News, start at the top: D. Trump.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.

Attachment: signature.asc
Description: PGP signature

Reply via email to