Again, I ran into a havoc update of CURRENT last night. While booting a
freshly installed kernel and performing "make -j4 installworld", the
box suddenly rebooted - out of the blue. 

With the wrecked CURRENT left behind (r327866), I'm not able to boot
even into single user mode. The box halts with a starnge BTX loader
message indicating

BTX halted

followed by a set of register dumps.

I saw this weird behaviour last year around November, when the boot
chain has been corrupted.

Well, when the strange "BTX halted" message doesn't appear, some other
strange message occurs claiming that there is no /boot/loader. 

I tried to investigate with the USB image created 10th January 2018
from ISO downloads and it showed, that /boot/ was obviously intact, but
files in /usr/sbin, /usr/bin were zero in size, also some libs
in /usr/lib and /lib. While /boot/ seemingly being already installed
while other portions failed, I knew from the past that I had to replace
all /boot, /bin, /sbin, /usr/sbin, /usr/bin, /lib, /usr/lib , /usr/libexec
and /libexec from the recent USB image. I did so via "pax -v -rw -pe",
but I had to "chflags noschg" some files/libraries on the target to get
them overwritten. I simply did a

chflags noschg * 

to every folder/subfolder and "pax'ed" the destination then. So far.
I'm able to boot into single user again, but when it comes to the
shell and /bin/sh is supposed to be executed, I get the strange

/lib/casper/: read error: Invalid argument

and the prompt is jumping back to ensure the PASSWORD (console is
password protected).

So, when using /rescue/sh (which is a remaining from the broken update
procedure), I'm able to have a shell in single user mode. But I have no
chance to repair the system by using the fully intact /usr/src
and /usr/obj infrastructure! Why? Again, when typing "make buildworld",
I'm bothered with 

/lib/casper/: read error: Invalid argument


make: "/usr/src/share/mk/" line 142: warning: "cc
--version|| echo 0.0.0" returned non-zero status

and a following line complaining about line 155: Unable to determin
compiler type for CC=cc. Consider setting COMPILER_TYPE.

Something is hindering to start the compiler somehow and it is related
to /lib/casper/: read error: Invalid argument?

What is wrong here? How to fix this?

 Again, the useless, minimalistic USB iamges provided by the site without compiler infrastructure are useless for
desaster recovery, since I can not simply boot into the image and
performing a DESTDIR-delegated installworld of an existing precompiled

How can I use the ISO image to rescue the system? I do not find
anything in recent docs. A couple of years ago such a task was possible
until some people started to get rid of the compiler/installation
infrastructure necessary to installworld. 

Thanks in advance for the help, kind regards,

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to