I have two FreeBSD 12-CURRENT amd64 systems that both refuse to install any
new packages.  "pkg update -f" doesn't help.  When I try, I get a confusing
error like this.

$ sudo pkg update -f
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01
Fetching packagesite.txz: 100%    6 MiB   3.0MB/s    00:02
Processing entries:   0%
pkg: Newer FreeBSD version for package py27-sphinxcontrib-websupport:
- package: 1200058
- running kernel: 1200056
pkg: repository FreeBSD contains packages for wrong OS version:
Processing entries: 100%
Unable to update repository FreeBSD
Error updating repositories

It's confusing because:
a) My running kernel actually is 1200058, as shown by "uname -K"
b) I don't have py27-sphinxcontrib-websupport installed, so what is it
complaining about?

Does anybody know what's going on?

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to