On 4/6/2018 12:40 PM, Ion-Mihai Tetcu wrote:
On Fri, 6 Apr 2018 08:39:27 -0700 (PDT)
"Rodney W. Grimes" <freebsd-...@pdx.rh.cn85.dnsmgr.net> wrote:

On Thu, 5 Apr 2018 22:38:51 -0700 (PDT)
"Rodney W. Grimes" <freebsd-...@pdx.rh.cn85.dnsmgr.net> wrote:

I'm trying to install FreeBSD on :
VMWare ESXi, 6.0.0, 5050593

Guest OS: FreeBSD (64-bit)
Compatibility: ESXi 6.0 and later (VM version 11)

For 11.1R I'm getting the boot menu, then:
/boot/kernel/kernel text=014972f8
elf64_loadimage: read failed
can't load file: '/boot/kernel/kernel': input/output error
(for 10.4R similar just with a different address).

SCSI Adapatr for the VM is set to LSI Logic (but I've tried
with the other available options with the same result).

VMWare docs list both 10 and 11 as being compatible with this
version of ESXi.
Any pointers to get through this will be greatly appreciated, I
didn't found anything on the net, and I need a sane system to
play with when I'm getting tired of the ton of Linux distros
I'm forced to use.
Try setting the BIOS emulation to BIOS instead of UEFI.
The WM is set:
Firmware: BIOS.
Boot Delay: 0ms
Force BIOS setup: No
Failed boot recovery: Do not automatically retry after virtual
machine fails to find a boot device EFI Secure Boot: Disabled
Those all look good from my experience.

And what image are you trying to boot from?
Are you trying to boot from a cd attached via vsphere client? or
is it a file on the server?
I've uploaded the ISOs on one of the data stores on the server,
didn't even tried from the client.
Ok, so that is also the same procedure I am trying.

Now, which .ISO is it?  Maybe you have a broken snapshots.  Lots of
bootcode work has been going on in -current.  Can you try the 11.1
release ISO either i386 or amd64?

I know that installs as I have done that many times.
Tried this one after 11.1 failed FreeBSD-10.4-RELEASE-amd64-bootonly.iso

I just downloaded the FreeBSD-11.1-RELEASE-amd64-bootonly.iso from the
data store and checked the sha256 against the one on the ftp site and
it's OK, so except if vshpere somehow corrupts files on upload and
fixes them on download I think the image is OK.
I usually use a .ISO when working with ESXi and FreeBSD as a
I'll try with the vmdk image of the release now.
I have NOT ever tried that, so have no data there.

I run these guest on ESXi 5.5 and ESXi 6.5, I do not have any
Hm, I guess I could try on 6.5 as an other cluster with has hosts
running VMware ESXi, 6.5.0, 4564106
It should just work, I have played with ESXi 6.0.0 at one
time or another and would have a good recollection if I had issues
booting any FreeBSD distributions on it.  At present I do not have
any 6.0.0 running, though I could fix that in a matter of minutes.
I relocated the VM on one of the 6.5.0 hosts (just the VM, not anything
else) and got the same result trying to boot the 10.4R boot-only ISO).
Would it make any diff if I create the VM from scratch on that host?

I have about 40 FreeBSD 10.3/10.4 VMs that were installed on a vSphere ESXi v6.0 cluster that has since been upgraded recently to v6.5. As a test, I just booted 11.1 from an ISO ( FreeBSD-11.1-RELEASE-amd64-disc1 ) using the FreeBSD-64bit OS template defaults and it reaches the installer welcome screen without issue. Here is a copy of the vmx file if you'd like to compare. Perhaps your host is selecting a different set of defaults for some reason? ...

[root@esxi1:/vmfs/volumes/552c8e27-b1f51fec-9bf8-90e2ba090e50/test-freebsd11] cat test-freebsd11.vmx
.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "13"
nvram = "test-freebsd11.nvram"
pciBridge0.present = "TRUE"
svga.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
floppy0.present = "FALSE"
numvcpus = "2"
memSize = "2048"
sched.cpu.units = "mhz"
sched.cpu.affinity = "all"
tools.upgrade.policy = "manual"
scsi0.virtualDev = "lsilogic"
scsi0.present = "TRUE"
scsi0:0.deviceType = "scsi-hardDisk"
scsi0:0.fileName = "test-freebsd11.vmdk"
sched.scsi0:0.shares = "normal"
sched.scsi0:0.throughputCap = "off"
scsi0:0.present = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.networkName = "Production A"
ethernet0.addressType = "vpx"
ethernet0.generatedAddress = "00:50:56:bc:a5:be"
ethernet0.present = "TRUE"
ide0:0.deviceType = "atapi-cdrom"
ide0:0.clientDevice = "TRUE"
ide0:0.fileName = "emptyBackingString"
ide0:0.present = "TRUE"
displayName = "test-freebsd11"
guestOS = "freebsd-64"
toolScripts.afterPowerOn = "TRUE"
toolScripts.afterResume = "TRUE"
toolScripts.beforeSuspend = "TRUE"
toolScripts.beforePowerOff = "TRUE"
uuid.bios = "42 3c ab 70 1b b3 53 b9-1f a4 f2 b4 2f a8 f2 e6"
vc.uuid = "50 3c 76 0f 06 b5 37 cc-50 f7 35 c4 c6 34 29 fe"
migrate.hostLog = "test-freebsd11-1927f738.hlog"
sched.cpu.min = "0"
sched.cpu.shares = "normal"
sched.mem.min = "0"
sched.mem.minSize = "0"
sched.mem.shares = "normal"
numa.autosize.vcpu.maxPerVirtualNode = "2"
numa.autosize.cookie = "20001"
sched.swap.derivedName = "/vmfs/volumes/552c8e27-b1f51fec-9bf8-90e2ba090e50/test-freebsd11/test-freebsd11-9923576a.vswp"
uuid.location = "56 4d 9b 92 f9 2e 4a 68-f6 6a b2 22 17 43 d5 7e"
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
ethernet0.pciSlotNumber = "32"
vmci0.pciSlotNumber = "33"
vmci0.id = "799601382"
monitor.phys_bits_used = "43"
vmotion.checkpointFBSize = "4194304"
vmotion.checkpointSVGAPrimarySize = "4194304"
cleanShutdown = "TRUE"
softPowerOff = "FALSE"
checkpoint.vmState = ""

Does the ESXi host install any another OS successfully? Perhaps your having a hardware issues of some sort.

Hope this helps,

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to