I am having problems getting XFree86 to run under
a recent version of -current and was hoping that
someone might be able to help me to figure out what
that problem is. At this point I very close to frustration
with this process, so might be overlooking something obvious.

Here is the situation:

I installed 4.1-RELEASE last week (full install, including XFree86). The X
server that comes with 4.1-R had problems with my video card (ATI Rage
Fury Maxx), so I installed the XFree86-4 port (XFree86 4.0.1),
reconfigured /etc/XF86Config, and was able to run XFree without any
problem (using the "r128" driver).

(OK, I am using 'startx' to start X, and this config did produce a few
messages on the tty about "memory already clear" or something like that,
but X did startup fine and was useable.)

I then cvsupped to -current on Sunday, and when I rebooted, XFree86
was catching signal 10, causing XFree86 to exit on signal 6
(according to the log file). (No change was made to the /etc/XFree86Config)

On Tuesday, I did another cvsup, with the same results.

Next, I did a cvsup on ports-all, cleaned all X11 components from my
system (including removing /usr/X11R6 and 'make clean' in /usr/ports), and
then tried to rebuild XFree86-4 from the ports.

After all of this, I still got the same exit condition from XFree86.
(I even tried using sw_cursor and noaccell in the config file, but that
didn't help, nor did using a different color depth or resolution.)

My next thought was that something else had changed on the system, 
so I updated the entire /etc directory from that contained in the -current
tree and rebooted, but that didn't seem to make any difference either.

I was able to get the standard VGA Xserver to run, but 320x200 resolution
is really not acceptable to me.

So, my question, has there been a change in the -current tree that would
cause a breakage in XFree86-4? Where would be a good place to look for
more information about this? (I have searched the mailing list archives
and have not found any information about this problem.) Am I just
overlooking something incredibly obvious here?

I have the log file that XFree86 dropped into /var/log, but do not
understand enough about what it is reporting for that to be helpful to me.

Some more information:

MB: Asus K7V
CPU: Athlon 750
Vid: ATI Rage Fury Maxx (dual Rage 128 Pro chipsets)

Thanks for any help,


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to