> On Mon, 4 Sep 2000, Brandon Hume wrote:
> Sounds similar to what I'm getting; after a boot I get a load of the
> following:
>   ahc0: ahc_intr - referenced scb not valid during SELTO (31, 255)

That's what I get... although I get SELTO (31, 0)

> Similar config to yours; a Tyan Thunder SMP BX with an onboard 7895

Mine's a GX, with a 7895 also (not 7890, oops...)

> controller.  I started getting this after my 29th Aug update, although
> this was a few days since the last working version I compiled (dmesg says
> the 24th so, er, I guess that's when it was)

My working kernel was built 1 PM ADT on the 26th, so there's a slightly
narrower window.

> Lots of other blurb about "can't allocate register resources" for just
> about anything on the PCI bus, as I recall.

I think that's a double-probe problem mentioned on the commit list.  Dunno
if it would be related.

Here's the kernel config and functional-dmesg I promised.


Copyright (c) 1992-2000 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #0: Sat Aug 26 13:00:17 ADT 2000
    [EMAIL PROTECTED]:/build/src/sys/compile/JASHUGAN
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium III/Pentium III Xeon/Celeron (501.14-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x673  Stepping = 3
real memory  = 134086656 (130944K bytes)
avail memory = 126570496 (123604K bytes)
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
FreeBSD/SMP: Multiprocessor motherboard
 cpu0 (BSP): apic id:  0, version: 0x00040011, at 0xfee00000
 cpu1 (AP):  apic id:  1, version: 0x00040011, at 0xfee00000
 io0 (APIC): apic id:  2, version: 0x00170011, at 0xfec00000
Preloaded elf kernel "JASHUGAN" at 0xc03e1000.
Pentium Pro MTRR support enabled
md0: Malloc disk
apm0: <APM BIOS> on motherboard
apm0: found APM BIOS v1.2, connected at v1.2
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82443GX host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
pci0: <Intel 82443GX host to PCI bridge> at 0.0
pcib2: <Intel 82443GX (440 GX) PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib2
pci1: <Matrox MGA G400 AGP graphics accelerator> at 0.0 irq 16
isab0: <Intel 82371AB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> port 0xffa0-0xffaf at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xef80-0xef9f irq 19 at device 
7.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ugen0: Logitech, Inc. Camera, rev 1.00/1.00, addr 2
uhub1: Texas Instruments UT-USB41 hub, class 9/0, rev 1.10/1.10, addr 3
uhub1: 4 ports with 4 removable, bus powered
ukbd0: Sun Microsystems Type 6 USB, rev 1.00/1.01, addr 4, iclass 3/1
kbd1 at ukbd0
ums0: Logitech USB-PS/2 Mouse, rev 1.00/1.10, addr 5, iclass 3/1
ums0: 3 buttons and Z dir.
Timecounter "PIIX"  frequency 3579545 Hz
pci0: <Intel 82371AB Power management controller> at 7.3
pcib3: <DEC 21152 PCI-PCI bridge> at device 16.0 on pci0
pci2: <PCI bus> on pcib3
pci2: <3Dfx Voodoo 2 graphics accelerator> at 4.0
pci2: <unknown card> (vendor=0x11d1, dev=0x01f7) at 5.0 irq 17
fxp0: <Intel Pro 10/100B/100+ Ethernet> port 0xef40-0xef5f mem 
0xfea00000-0xfeafffff,0xfd2ff000-0xfd2fffff irq 19 at device 17.0 on pci0
fxp0: Ethernet address 00:e0:81:10:24:79
ahc0: <Adaptec aic7895 Ultra SCSI adapter> port 0xe400-0xe4ff mem 
0xfebfe000-0xfebfefff irq 16 at device 18.0 on pci0
ahc0: aic7895 Wide Channel A, SCSI Id=7, 32/255 SCBs
ahc1: <Adaptec aic7895 Ultra SCSI adapter> port 0xe800-0xe8ff mem 
0xfebff000-0xfebfffff irq 16 at device 18.1 on pci0
ahc1: aic7895 Wide Channel B, SCSI Id=7, 32/255 SCBs
pcm0: <Creative EMU10K1> port 0xef20-0xef3f irq 16 at device 19.0 on pci0
pcib1: <Intel 82443GX host to AGP bridge> on motherboard
pci3: <PCI bus> on pcib1
isa0: too many memory ranges
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> on isa0
sc0: VGA <16 virtual consoles, flags=0x200>
unknown: <PNP0303> can't assign resources
unknown: <PNP0700> can't assign resources
APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
IPsec: Initialized Security Association Processing.
IP Filter: v3.4.9 initialized.  Default = pass all, Logging = enabled
SMP: AP CPU #1 Launched!
acd0: DVD-ROM <CREATIVEDVD-ROM DVD2240E 03/18/98> at ata0-master using WDMA2
Waiting 7 seconds for SCSI devices to settle
Mounting root from ufs:/dev/da0s2a
cd0 at ahc0 bus 0 target 3 lun 0
cd0: <MATSHITA CD-R   CW-7501 2.00> Removable CD-ROM SCSI-2 device 
cd0: 5.000MB/s transfers (5.000MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present
da2 at ahc0 bus 0 target 2 lun 0
da2: <MICROP 3221-10   1128RV 28RV> Fixed Direct Access SCSI-2 device 
da2: 10.000MB/s transfers (10.000MHz, offset 15)
da2: 1955MB (4004219 512 byte sectors: 255H 63S/T 249C)
da1 at ahc0 bus 0 target 1 lun 0
da1: <SEAGATE ST32272W 0876> Fixed Direct Access SCSI-2 device 
da1: 40.000MB/s transfers (20.000MHz, offset 8, 16bit)
da1: 2157MB (4419464 512 byte sectors: 255H 63S/T 275C)
da0 at ahc0 bus 0 target 0 lun 0
da0: <HITACHI DK319H-18WC HF8G> Fixed Direct Access SCSI-2 device 
da0: 40.000MB/s transfers (20.000MHz, offset 8, 16bit)
da0: 17366MB (35566480 512 byte sectors: 255H 63S/T 2213C)

And, of course, the kernel config... a fair amount of crap still not trimmed
out, but the only difference between this config and the one used to build
the functional kernel is apm commented out and ACPI added, which I've already
tried reversing without much difference.

ident           JASHUGAN
machine         i386
maxusers        32

cpu             I686_CPU
options         CPU_FASTER_5X86_FPU
options         NO_F00F_HACK
options         DDB

hints           "JASHUGAN.hints"        #Default places to look for devices.

options         INET                    #InterNETworking
options         INET6                   #IPv6 communications protocols
options         IPSEC                   #IP security
options         IPSEC_ESP               #IP security (crypto; define w/ IPSEC)
options         FFS                     #Berkeley Fast Filesystem
options         FFS_ROOT                #FFS usable as root device [keep this!]
options         SOFTUPDATES             #Enable FFS soft updates support
options         MFS                     #Memory Filesystem
options         MD_ROOT                 #MD is a potential root device
options         NFS                     #Network Filesystem
options         NFS_NOSERVER            # Jashugan is not an NFS server
options         MSDOSFS                 #MSDOS Filesystem
options         CD9660                  #ISO 9660 Filesystem
options         PROCFS                  #Process filesystem
options         COMPAT_43               #Compatible with BSD 4.3 [KEEP THIS!]
options         SCSI_DELAY=7500         #Delay (in ms) before probing SCSI
options         UCONSOLE                #Allow users to grab the console
options         USERCONFIG              #boot -c editor
options         VISUAL_USERCONFIG       #visual boot -c editor
options         KTRACE                  #ktrace(1) support
options         SYSVSHM                 #SYSV-style shared memory
options         SYSVMSG                 #SYSV-style message queues
options         SYSVSEM                 #SYSV-style semaphores
options         P1003_1B                #Posix P1003_1B real-time extensions
options         KBD_INSTALL_CDEV        # install a CDEV entry in /dev
options         RANDOMDEV               # entropy device

# To make an SMP kernel, the next two are needed
options         SMP                     # Symmetric MultiProcessor Kernel
options         APIC_IO                 # Symmetric (APIC) I/O
# Optionally these may need tweaked, (defaults shown):
options         NCPU=2                  # number of CPUs
#options        NBUS=8                  # number of busses
#options        NAPIC=1                 # number of IO APICs
#options        NINTR=24                # number of INTs

device          isa
device          eisa
device          pci

# Floppy drives
device          fdc

# ATA and ATAPI devices
device          ata
device          atadisk                 # ATA disk drives
device          atapicd                 # ATAPI CDROM drives
device          atapifd                 # ATAPI floppy drives
device          atapist                 # ATAPI tape drives
options         ATA_STATIC_ID           #Static device numbering
options         ATA_ENABLE_ATAPI_DMA    #Enable DMA on ATAPI devices

# SCSI Controllers
device          ahc             # AHA2940 and onboard AIC7xxx devices
options         AHC_ALLOW_MEMIO

# SCSI peripherals
device          scbus           # SCSI bus (required)
device          da              # Direct Access (disks)
device          sa              # Sequential Access (tape etc)
device          cd              # CD
device          pass            # Passthrough device (direct SCSI access)

# atkbdc0 controls both the keyboard and the PS/2 mouse
device          atkbdc  1
device          atkbd
device          psm

device          vga

# splash screen/screen saver
device          splash

# syscons is the default console driver, resembling an SCO console
device          sc      1

# Floating point support - do not disable.
device          npx

# Power management support (see LINT for more options)
#device         apm
device          acpi
options         ACPI_DEBUG
options         AML_DEBUG

device          fxp             # Intel EtherExpress PRO/100B (82557, 82558)

# Pseudo devices - the number indicates how many units to allocated.
device          loop            # Network loopback
device          ether           # Ethernet support
device          sl              # Kernel SLIP
device          ppp     1       # Kernel PPP
device          tun             # Packet tunnel.
device          pty             # Pseudo-ttys (telnet etc)
device          md              # Memory "disks"
device          gif     4       # IPv6 and IPv4 tunneling
device          faith   1       # IPv6-to-IPv4 relaying (translation)

# The `bpf' device enables the Berkeley Packet Filter.
# Be aware of the administrative consequences of enabling this!
device          bpf             # Berkeley packet filter

# USB support
device          uhci            # UHCI PCI->USB interface
device          ohci            # OHCI PCI->USB interface
device          usb             # USB Bus (required)
#device         udbp            # USB Double Bulk Pipe devices
device          ugen            # Generic
device          uhid            # "Human Interface Devices"
device          ukbd            # Keyboard
device          ulpt            # Printer
device          umass           # Disks/Mass storage - Requires scbus and da
device          ums             # Mouse
device          urio            # Diamond Rio 500 MP3 player

options         IPFILTER
options         IPFILTER_LOG

device          pcm

Brandon Hume    - hume -> BOFH.Halifax.NS.Ca, http://WWW.BOFH.Halifax.NS.Ca/

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to