Kernels after the SMPng commit have failed to boot for me. The pc is an
old TYAN S1563D with a pair of p200's. I have tracked it down to entering
vm86_intcall() in getmemsize(). It enters but doesn't return. I haven't
seen any similar problems on the lists.

I've tried building a UP kernel too, same result. Dies in the
vm86_intcall(). Build optimization is the default -O. dmesg from a Sept 6
kernel, prior to the SMPng commit is attached.

dave adkins

Copyright (c) 1992-2000 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #100: Wed Sep  6 07:53:53 CDT 2000
Timecounter "i8254"  frequency 1193056 Hz
CPU: Pentium/P54C (199.41-MHz 586-class CPU)
  Origin = "GenuineIntel"  Id = 0x52c  Stepping = 12
real memory  = 100663296 (98304K bytes)
avail memory = 94015488 (91812K bytes)
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
FreeBSD/SMP: Multiprocessor motherboard
 cpu0 (BSP): apic id:  0, version: 0x00030010, at 0xfee00000
 cpu1 (AP):  apic id:  1, version: 0x00030010, at 0xfee00000
 io0 (APIC): apic id:  2, version: 0x00170011, at 0xfec00000
Preloaded elf kernel "kernel" at 0xc03c0000.
Preloaded elf module "nfs.ko" at 0xc03c009c.
Preloaded elf module "linux.ko" at 0xc03c0138.
Intel Pentium detected, installing workaround for F00F bug
stray irq 7
VESA: v2.0, 8192k memory, flags:0x1, mode table:0xc02f3ae2 (1000022)
VESA: Matrox Graphics Inc.
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
isab0: <Intel 82371SB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX3 ATA controller> port 0xf000-0xf00f at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pci0: <Matrox MGA Millennium 2064W graphics accelerator> at 17.0 irq 19
ahc0: <Adaptec 2940 Ultra SCSI adapter> port 0x6000-0x60ff mem 0xe0804000-0xe0804fff 
irq 18 at device 18.0 on pci0
ahc0: aic7880 Wide Channel A, SCSI Id=7, 16/255 SCBs
de0: <Digital 21140A Fast Ethernet> port 0x6500-0x657f mem 0xe0805000-0xe080507f irq 
17 at device 19.0 on pci0
de0: Cogent EM100FX 21140A [10-100Mb/s] pass 2.2
de0: address 00:00:92:97:3a:5d
de0: enabling 100baseFX port
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10000000 on isa0
sio0: type 16550A lookalike with 16 bytes FIFO
sio1 at port 0x2f8-0x2ff irq 3 flags 0x10000000 on isa0
sio1: type 16550A lookalike with 16 bytes FIFO
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/15 bytes threshold
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
vpo0: <Iomega VPI0 Parallel to SCSI interface> on ppbus0
vpo0: EPP 1.9 mode
sbc0: <Soundblaster 16> at port 0x260-0x26f irq 5 drq 3 on isa0
sbc0: setting card to irq 5, drq 3
pcm0: <SB DSP 4.11> on sbc0
unknown: <PNP0303> can't assign resources
atspeaker0: <AT speaker> at port 0x61 on isa0
unknown: <PNP0501> can't assign resources
unknown: <PNP0700> can't assign resources
unknown: <PNP0401> can't assign resources
unknown: <PNP0501> can't assign resources
APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
SMP: AP CPU #1 Launched!
ad0: 1033MB <ST31220A> [2099/16/63] at ata0-master using WDMA2
ad1: 19531MB <Maxtor 92048U8> [39683/16/63] at ata0-slave using WDMA2
ad2: 2015MB <Conner Peripherals 2113MB - CFA2161A> [4095/16/63] at ata1-master using 
Waiting 2 seconds for SCSI devices to settle
da0 at ahc0 bus 0 target 0 lun 0
da0: <SEAGATE ST32550N 0021> Fixed Direct Access SCSI-2 device 
da0: 10.000MB/s transfers (10.000MHz, offset 15)
da0: 2047MB (4194058 512 byte sectors: 255H 63S/T 261C)
da1 at ahc0 bus 0 target 1 lun 0
da1: <SEAGATE ST32550N 0021> Fixed Direct Access SCSI-2 device 
da1: 10.000MB/s transfers (10.000MHz, offset 15)
da1: 2047MB (4194058 512 byte sectors: 255H 63S/T 261C)
da2 at vpo0 bus 0 target 6 lun 0
da2: <IOMEGA ZIP 100 D.09> Removable Direct Access SCSI-2 device 
da2: Attempt to query device size failed: NOT READY, Medium not present
Mounting root from ufs:/dev/ad2s1a

Reply via email to