On Sun, 29 Oct 2000, John W. De Boskey wrote:

>    I ran into an interesting gotcha with fsck and vinum...
>    I have the following line in /etc/fstab:
> /dev/vinum/raid5        /pub            ufs     rw              2       2
>    and during an upgrade (old current to current), I commented the
> line out during the reboot process. After bringing the new system
> online, I executed:
> /sbin/fsck -y /dev/vinum/raid5
> and received the following error:
> fsck: exec /usr/sbin/fsck_unused for /dev/vinum/raid5: No such file or directory

I saw a related problem with mfs.  I had the following lines in /etc/fstab:

#/dev/ad0s4     none            swap    sw

/dev/ad0s4      /tmp            mfs     rw,-s65536,-i8192,noatime,noauto

The mfs line has very little to do with /dev/ad0s4 or swap.  The label
for /dev/ad0s4 just provides a (bogus) geometry for mfs.  I wasn't
using /dev/ad0s4 for either swap or mfs, but it happened to have a
filesystem on it, and when I tried to fsck this, fsck attempted to
exec the nonexistent file fsck_mfs.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to