* Warner Losh <[EMAIL PROTECTED]> [001107 13:14] wrote:
> In message <[EMAIL PROTECTED]> Bill Fumerola writes:
> : On Tue, Nov 07, 2000 at 01:13:41PM -0700, Warner Losh wrote:
> : 
> : > I just tried to umount -f /home, where /home was an NFS mounted file
> : > system on a network that was no longer attached to my laptop.  In the
> : > past this has just worked, even if processes were hung in disk wait
> : > state.  When I tried it last night on an Oct 29th kernel, I got EBUSY
> : > and the file system remained mounted.
> : > 
> : > This can't be right.  Is there any way to really force it short of a
> : > reboot?
> : 
> : That's just the way it seems to be.
> It didn't used to be this way.
> : Mount with 'intr,soft' for better luck with this.
> Things weren't stuck in disk wait, but they still returned EBUSY.
> Force means force, damnit!

Yes, this used to work quite well for some time, I have no idea
who broke it.  Maybe you can sprinkle some printfs in the code and
narrow it down a bit?

"I have the heart of a child; I keep it in a jar on my desk."

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to