I have an IBM T20 laptop that I want to run FreeBSD on.  I have run
Partition Magic and shrunk the disk to 4GB (leaving 8GB for FreeBSD).
I downloaded 4.2-RELEASE and installed it on the box.  Everything looked
good until I tried to reboot the machine.  At that point, it would show
the ThinkPad Logo, tinker, then the screen would dim, the hard drive light
stuck on, and the box just sat there (for 3 hours, as a test 8).

The company we lease the machine from had to give me a new hard drive to
fix the problem.  Luckily I don't keep anything I care about on this
machine.  Assuming the problem was a hardware issue, I tried it again,
with the same results.  This time I got IBM involved, and they said that
the T20 checks for data on the hard drive (kinda sounded like the CMOS was
too small for all the stuff they saved between boots).  From what they
told me, the data is stored somewhere in those 62 sectors after the boot
block, before the first partition.

Okay, so I am now on my third hard drive, and I decided to try it one more
time (glutton for punishment).  This time I tried a 5.0 snapshot dated
2000/12/23.  The install looked good, and I even got it to boot both NT
and FreeBSD from the drive (in that order).  After I gave FreeBSD the
3-finger salute to shut it down, the system would no longer boot.
Through experimentation, I have found that I can:

        1) Pull hard drive out
        2) power on and wait until red error saying drive is missing
        3) plug drive in hot (don't tell IBM 8)
        4) boot from FreeBSD boot/root disks
        5) drive works when mounted using custom install option then a
                holographic shell.

I can even copy files to/from the hard drive across the network (okay, I
am bored and desparate).  Everything works except booting from the drive.
Using dd|od -c, it appears that boot0 is overlapping onto the second 
sector (which I thought was a no-no).  Also, boot1 or boot2 (I forget
which now) was in sectors 3-x, and I thought those should be in the boot
area of the FreeBSD partition, right?  I have attempted to replace the
boot record (even using a standard MBR).  I finally got so frustrated that
I dd'd /dev/zero into those 62 sectors in hope the IBM would assume it was
a new drive and re-create the data it needed.

Any ideas?
- brian

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to