Hello Marcel,

On Fri, Feb 09, 2001 at 10:23:16AM -0800, Marcel Moolenaar wrote:
> [taken to -ports]

I see it nowhere in the headers, so I am going to add a Cc: for it...

> The link is correct. On a Redhat 6.2 system:
> dhcp00% cd /mnt/usr/lib
> dhcp00% ls -al X11
> lrwxrwxrwx  1 root  wheel  16 Jul 18  2000 X11 -> ../X11R6/lib/X11
> dhcp00% more /mnt/etc/redhat-release 
> Red Hat Linux release 6.2 (Zoot)

Which is not the point:-)

> > Solution: ? ( Maybe create the directory once we symlink to it? Seems like
> > a good idea... )
> Can you tell me what the problem was. I missed that.

The problem if you want it that way, is that although the symlink is
created upon installing linux_base, the directory it points to is not.
Hence the ${SUBJECT} about a "Dangling symlink". (If you install
linux_devtools, the directory is created, since there is a subdir in it.
That's why the problem may be harder to detect:-)

Maybe it would be a good idea to create a (empty if need be)
/usr/compat/linux/usr/X11R6/lib/X11 directory upon installing linux_base?

I have no idea how this came up btw, maybe some installation of some
third-party sw tried to follow the symlink and got confused? I just tried
to react to the problem at hand...

> > (Most probably this problem never surfaced before because the maintainers
> > had both ports installed on their systems.)
> I do have both ports in fact :-)

Me too, that's why I at first very self-confidently posted something along
the lines of "It works for me!" which earned blank stares from just about
anybody else:-) 

Szilveszter ADAM
Szeged University
Szeged Hungary

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to