On Wed, 7 Mar 2001, Leif Neland wrote:

> I've got a USB programmer for my Flashram for my Garmin GPS.
> It doesn't work, and causes blue screen under windows...
> Is this the proof for it is broken?
> Copyright (c) 1992-2001 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>       The Regents of the University of California. All rights reserved.
> FreeBSD 5.0-CURRENT #6: Tue Mar  6 19:17:59 CET 2001
> uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xb400-0xb41f irq 9 at device 
>4.2 on pci0
> usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
> usb0: USB revision 1.0
> uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> usbd_new_device: addr=2, getting first desc failed
> uhub_explore: usb_new_device failed, error=IOERROR
> uhub0: device problem, disabling port 1
> It can't be because FreeBSD doesn't know the USB programmer; it
> doesn't know my USB webcam either, and it still shows up as ugen
> with manufacturer name at boot.

I run -STABLE, and was pondering over a problem I've been having with
a USB device when I saw your problem.  Could you try something?
After you get that error above, move the device to the another USB
port.  I can manage to panic my system by doing that, except I'm doing
it with a USB gamepad.  I'm curious if it'll do the same for you.

The way that I've come about that error is different from how you got
there, though.  I have a problem where any time I access my IDE hard
drive (where Windows is -- FreeBSD is on SCSI disks), the USB gamepad
I have plugged in goes nuts and FreeBSD eventually shuts the USB port
off.  I know it isn't a FreeBSD-specific problem, because exactly the
same "nuttyness" happens when I'm in Windows.  The problem with
FreeBSD is, after FreeBSD has disabled the USB port, if I remove the
device and then plug it back in the same port, I get the same error
you've posted above.  I can plug/unplug forever and still get that
error, as long as I'm using the same USB port.  But as soon as I plug
it into the the other USB port on the root hub (my only "hub"), the
system panics.  Nick? :-)

I'd have a crashdump for Nick or someone else to look at already, but
I found out the hard way that the amr(4) driver doesn't take
crashdumps.  I then tried using a SCSI ZIP drive for the crashdump
after labeling it and pointing dumpon(8) at it, which worked fine,
until I tried to actually get the crashdump off of the drive after the
crash.  dumpon(8) won't accept the device (/dev/da0s1b in this case)
so that I can use savecore to get the dump back off of it, but it
accepted it to put it on it!  Anyone know why that is happening?  I
don't remember the exact error dumpon was giving me at this time,
sorry.  I'll get it tonight if this doesn't ring a bell for someone.

   FreeBSD: The fastest and most stable server OS on the planet.
   For IA32 and Alpha architectures. IA64, PPC, and ARM under development.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to