Since I first saw this, I've CVSupped a couple of times; most recent time
ended at 11:32:39 hrs. PST (8 hrs. west of GMT/UTC) today.

And I blew away /usr/obj completely (just in case anything was left
lying about), and tried it with the GENERIC kernel (vs. my customized
one); I'm not able to get beyond:

machine -> /usr/src/sys/i386/include
echo "#define INET 1" > opt_inet.h
touch opt_inet6.h
rm -f .depend
mkdep -f .depend -a   -nostdinc -D_KERNEL -DKLD_MODULE -I- -I. -I@ -I@/dev 
-I@/../include -I/usr/obj/usr/src/i386/usr/include  
===> if_ef
@ -> /usr/src/sys
machine -> /usr/src/sys/i386/include
echo "#define IPX 1" > opt_ipx.h
echo "#define INET 1" > opt_inet.h
echo "

echo "

echo "

echo "

rm -f .depend
mkdep -f .depend -a   -nostdinc -D_KERNEL -DKLD_MODULE -I- -I. -I@ -I@/dev 
-I@/../include -I/usr/obj/usr/src/i386/usr/include  
/usr/src/sys/modules/if_ef/../../net/if_ef.c:31: opt_ef.h: No such file or directory
mkdep: compile failed
*** Error code 1

Stop in /usr/src/sys/modules/if_ef.
*** Error code 1

Stop in /usr/src/sys/modules.
*** Error code 1

Stop in /common/obj/C/usr/src/sys/GENERIC.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
m758712358[3] ^Dexit

Script done on Fri Mar 16 15:39:27 2001

The "make buildworld" worked OK.  And here are the non-comment lines
from my /etc/make.conf:

CFLAGS= -O -pipe
INSTALL=install -C
COMPAT22=       yes
COMPAT3X=       yes
HAVE_MOTIF=     yes
SUP_UPDATE=     yes
SUP=            /usr/local/bin/cvsup
SUPFLAGS=       -g -L 2
SUPFILE=        /usr/local/etc/4.x-stable-supfile

I was able to build -STABLE (4.3-BETA) -- on a different slice (/S2) --
just fine this morning:

Filesystem  1K-blocks     Used    Avail Capacity  Mounted on
/dev/ad0s4a     95263    58334    29308    67%    /
devfs               1        1        0   100%    /dev
/dev/ad0s1a     95263    39770    47872    45%    /S1
/dev/ad0s1e    915695   692461   149979    82%    /S1/usr
/dev/ad0s2a     95263    39770    47872    45%    /S2
/dev/ad0s2e    915727   698177   144292    83%    /S2/usr
/dev/ad0s4e    915727   718513   123956    85%    /usr
/dev/ad0s4g    254063    74919   158819    32%    /var
/dev/ad0s4h  14116697  2619712 10367650    20%    /common
procfs              4        4        0   100%    /proc
/dev/md10c     520140       12   478520     0%    /tmp

I figure there's something likely obviously silly I'm overlooking, but
I've been banging my head against whatever's handy for a little too
long....  :-(

Oh -- one other thing:  there is too a file named opt_ef.h; it's in
/usr/obj/usr/src/sys/${KERNCONF}, and it's empty.  (The /usr/obj that's
on ad0s4e is a symlink to /common/obj/C, in case that's confusing
anyone.  I have 2 -STABLE slices & one -CURRENT that are bootable.)

I would welcome clues.

David H. Wolfskill                              [EMAIL PROTECTED]
As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to