On 19 Mär, Ruslan Ermilov wrote:

> 5.  This affects not only ppp(8).  Add default route that points to the
>     LAN; change the IP address on interface; observe that the default
>     route has gone away.  The reason is that if we don't do this, we
>     may end up using the old (now non-existing) local IP address.

Yesterday I did a buildworld and an installworld with sources which
contain the fixed routing code (cvsup at ~3pm CET). Today I tried to
dialout-on-demand right after boot. I use ISDN and have
  defaultrouter="-interface isp1"
in my rc.conf. It didn't worked and I found the reason withhin a minute.
There wasn't a defaultroute. So I just added the defaultroute and
everything was fine... until the next time my system tried to
dialout-on-demand. There wasn't a defaultroute again. Boring. Ok, I just
added the defaultroute again and the system dialed out. After this
second "route add default -interface isp1" the defaultroute didn't
disappeared for several dialouts. I haven't rebooted yet to try to
reproduce it.

Perhaps some interesting facts:
(33) netchild@ttyp2 % ifconfig isp1        
isp1: flags=a010<POINTOPOINT,LINK1,MULTICAST> mtu 1500
        inet --> netmask 0xffff0000 
        ether 00:00:00:00:00:00 
[Yes, it's down at the moment, I didn't want to dialout at the moment.]

(34) netchild@ttyp2 % route -vn get default
u: inet; u: inet; u: link ; RTM_GET: Report Metrics: len 168, pid: 0, 
seq 1, errno 0, flags:<UP,GATEWAY,STATIC>
locks:  inits: 
sockaddrs: <DST,NETMASK,IFP>
 default default 
   route to: default
destination: default
       mask: default
  interface: isp1
 recvpipe  sendpipe  ssthresh  rtt,msec    rttvar  hopcount      mtu     expire
       0         0         0         0         0         0      1500         0 

locks:  inits: 
 default isp1: default isp1: default

(35) netchild@ttyp2 % netstat -nr
Routing tables

Destination        Gateway            Flags     Refs     Use     Netif Expire
default            0:0:0:0:0:0        USc        37        3     isp1              UH          0        0     isp1          UH          2    31942      lo0

Don't worry if this problem is solved by the commit which fixed a PR
(I've seen it on cvs-all, but hadn't time to have a look at it).


                   It's not a bug, it's tradition!

http://www.Leidinger.net                       Alexander @ Leidinger.net
  GPG fingerprint = C518 BC70 E67F 143F BE91  3365 79E2 9C60 B006 3FE7

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to