On Mon, Apr 16, 2001 at 12:36:10PM -0700, walt said:
> I just upgraded a fresh install of 4.2 to CURRENT.  Everything
> seemed to go great until I discovered that I have only a small
> subset of the standard entries in /dev and there is no
> /dev/MAKEDEV or /dev/MAKEDEV.local.
> I re-cvsup'd again this morning and repeated the entire
> makeworld makekernel installkernel installworld mergemaster
> cycle a second time.
> It all went great except that I still have no MAKEDEV in /dev
> and very few entries in /dev, all of which are dated today.
> I've tried using 'install' to move /usr/src/etc/MAKEDEV into
> /dev, and tried cp and mv and even did a 'make distribution'
> from /usr/src/etc and always get an 'operation not supported'
> error message.
> I did all these things in single-user mode, BTW.
I don't run -CURRENT, but check your kernel configuration for "devfs", this
basically dynamically creates /dev entries when required, rather than having
the entire lot there.  Have you actually had any problems with the machine
as a result of the tiny amount of /dev entries?  If not, I wouldn't worry
too much.

"People who bite the hand that feeds them usually lick the boot that kicks
them." -- Unknown.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to