This is really a 'ports' issue...

I don't know why this happens. It was suggested that it was probably a bug in
nsrexecd- malloc maybe. Possibly.  It doesn't always happen, as it's happily
running right now on at least one i386 running -current (June 3) and one alpha
(June 2)- but don't let the dates spoof you as these systems were fine a month
ago as well.

Since all nsrexecd does is open a socket range and start listening so that a
remote server can connect and do NSR style authentication, and that nsrexecd
has been reported to die right away if it dies at all, one can presume that
each instance does just about the same thing.

I don't know why it's actually dying- and I don't have a debug version of it
built to really debug. I also consider -current to be more or less
'unsupported'- I sure as hell wouldn't commit any data worth backing up to a
system running it.

At the point in time that -current gets a bit more stable, I'll probably build
a new version anyway (it's time- the current client version is pretty old by
now). If it reproducibly starts dying for me, I'll probably debug it then.


> Gentlemen,
> I try to run (any) legato client on fBSD -current and so far had no
> success. All clients i tried (nwclient from ports, nwclient from release
> 3) exit on a siganl 11:
> luna /boot/kernel/kernel: pid 16940 (nsrexecd), uid 0: exited on signal
> 11 (core dumped)
> Strange enough  even the "original" linux legato client with
> compat_linux crashes with the same error
> Any hint ?
> Thanks in advance,
> --Armin

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to