>Date: Fri, 20 Jul 2001 10:57:02 +0700 (NOVST)

>>> >     With a July 18, 2001 sources, it seems like the kernel hands at
>>> >the entropy harvesting stage.... ctrl-t shows:

>>> Also (again, for me) "sysctl -N -a" outputs a (non-terminating) stream of
>>> ...

>       I have some kind of "workaround" (see the patch).
>In my config without this patch 'sysctl -a' hungs at net.inet.accf
>and with this patch it successfully run up to the end.
>I can not see what is wrong with the lines disabled by the patch.

After building today's -CURRENT OK (and observing that the behavior was
still the same for my custom kernel), I tried building a GENERIC kernel.
Much to my surprise (and different from my experience on 06 July --
last time I had built a GENERIC kernel for -CURRENT), that kernel did
not exhibit the symptoms.

I've now managed to circumvent the problem by:

* Removing the "device  pcm" specification in my custom kernel config.

* Adding the lines


  to /boot/loader.conf

* Re-building the kernel.  (cd /usr/src; make kernel KERNCONF=LAPTOP_30W)

* Re-booting.

It took a few tries to get things quite right, but sound works again;
thanks to the patch in http://www.FreeBSD.org/cgi/query-pr.cgi?pr=26854,
I'm (still) able to use the keyboard Fn+End chord to mute the sound
during boot (so that process is less disruptive in meetings).  (BTW, it
would be nice to get that tiny little patch in before 4.4-R.  Please?)

And yes, Linux emulation still works.

David H. Wolfskill                              [EMAIL PROTECTED]
As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to