/usr/bin/passwd in the latest -current world build with kernel
        build seems to do the following:
        # passwd joeuser
        Changing local password for joeuser.
        New password:
        Retype new password:
        passwd: updating the database...
        passwd: done
        and 5 seconds later, the machine would just freeze solid.  With
        yesterday's buildworld, it would do the same thing except
        it would panic the kernel and go into the db> prompt.  So
        the only way is to hard reboot which will goto single user mode
        where fsck would have to be done and then somehow the passwd
        database is corrupted which requires copying master.passwd.bak
        from /var/backups to /etc/master.passwd and then run and exit
        vipw with :wq to rebuild the passwd database.  Otherwise, all
        users besides root will be able to logon and /etc/passwd and
        /etc/master.passwd will be a bunch of garbled characters.
        vipw works fine when manually entering the encrypted passwd as
        a cut and paste from another system.  It isn't a hardware issue
        since I have tried everything from make -j 4 buildworld to
        running dnetc to even running cpuburn from the /usr/ports/misc
        collection which had no effect.  Only when running passwd would
        it hang the machine solid 5 seconds later each time and corrupt
        the password database.  The 6/18/2001 current binary snapshot
        from current.freebsd.org worked without any problems.

Vince - [EMAIL PROTECTED] - Vice President             ________   __ ____
Unix Networking Operations - FreeBSD-Real Unix for Free / / / / |  / |[__  ]
WurldLink Corporation                                  / / / /  | /  | __] ]
San Francisco - Honolulu - Hong Kong                  / / / / / |/ / | __] ]
HongKong Stars/Gravis UltraSound Mailing Lists Admin /_/_/_/_/|___/|_|[____]
Almighty1@IRC - oahu.DAL.NET Hawaii's DALnet IRC Network Server Admin

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to