Brooks Davis wrote:
> On Wed, Sep 12, 2001 at 04:59:16PM -0700, Doug Ambrisko wrote:
> > I just tried using tap in current.  In both cases I don't see the
> > /dev/tapX devices with devfs and accessing it without devfs doesn't
> > work reporting "Device not configured".  I tried it as a module and
> > built into the kernel.  Does anyone have this working?
> With devfs, you just need to try opening the device and you'll get it if
> it's not busy.  You can also open /dev/tap and get an arbitrary one.
> This is due to tun(4) style cloning code I committed recently.  I'm not
> actually sure this is the way we want to handle cloning hybrid devices,
> but there is precident so I committed the patch.  I think we may want to
> move to a model were we use interface cloning rather then devfs cloning
> because it will work in stable.

just cvsup'ed new sources and compiled/installed new kernel.
everything seems to work fine. at least without DEVFS. i will
do full buildword tomorrow and test more.


p.s. building DEVFS enabled kernel now....

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to