I am having problems doing a buildworld.  When I run it, I get the
following error:

cd /home/src/usr.bin/xinstall;  make obj;  make depend;  make all;  make
cc -O -pipe    -I/usr/obj/home/src/i386/usr/include   -static -o xinstall
xinstall.o: In function `main':
xinstall.o(.text+0x8f): undefined reference to `strtofflags'

I checked in /usr/lib/libc.a and got:

root@china (/usr/src)> nm /usr/lib/libc.a | grep strtofflags
00000088 T strtofflags

So I know it exists.  I did a 'ranlib /usr/lib/libc.a', and also did an
'ar s /usr/lib/libc.a', neither seemed to help.  I did an upgrade from
install floppies to the 20010909 snapshot from current.freebsd.org, and I
still get the same error.  I was able to rebuild my kernel successfully
after I updated, so I know the compiler and linker are mostly working.

I tried to rebuild some out of date utilites (zip-5.40 upgrade to
zip-5.42), as another experiment and I get:

cc -o zip -s zip.o zipfile.o zipup.o fileio.o util.o globals.o crypt.o
ttyio.o  unix.o crc32.o crctab.o deflate.o trees.o match.o crc_i386.o
fileio.o: In function `tempname':
fileio.o(.text+0xc8e): warning: mktemp() possibly used unsafely; consider
using mkstemp()
unix.o: In function `version_local':
unix.o(.text+0x8a2): undefined reference to `__xuname'

Once again I checked with 'nm' and I got:

root@china (/usr/ports/archivers/zip)> nm /usr/lib/libc.a | grep __xuname
         U __xuname
         U __xuname
00000000 T __xuname

So it also exists.  Then, out of boredom/desperation, I did:

root@china (/tmp)> ar x /usr/lib/libc.a __xuname.o
root@china (/tmp)> ar ruv /usr/lib/libc.a __xuname.o
r - __xuname.o
root@china (/tmp)> ranlib /usr/lib/libc.a

And I still get the same results from the make in zip.

Anybody else have another suggestion?

- brian

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to