I have applied the KSE patches to vmware2 that were posted on
http://www.ripe.net/home/mark/files/vmware2_kse.patch.tgz.  I can now
build vmware2, but run into a number of permission problems running

1.  Xlib: connection to ":0.0" refused by server
    Xlib: Client is not authorized to connect to Server
    Error: Can't open display: :0

    Can be worked around by "chmod 644 ~/.Xauthority".

2.  Cannot open /dev/tty0: permission denied (in a GUI message box).

    Linux /dev/tty0 seems to refer to FreeBSD /dev/ttyv0,
    using a chain of two symlinks.  "chown $USER /dev/ttyv0" doesn't
    seem to be effective, but "chmod 666 /dev/ttyv0" makes the message
    go away.

3.  Active virtual terminal (/dev/tty9) is not valid. Permission
    denied.  (in a GUI message box).

    Seems to be like the above, Linux tty9 is really FreeBSD ttyv8,
    and a chown is ineffective but a chmod 666 solves it.

4.  Warning: Tried to connect to session manager, Authentication
    Rejected, reason : None of the authentication protocols specified
    are supported and host-based authentication failed

    on stderr.  Don't know if this is a problem or just a warning.

5.  Permission error creating lockfiles (vmware-lock.whoever)

    The directory is owned by me.

In summary, it seems as though the vmware binary (which is SUID root)
is unable to access any files that are only accessible to the invoking
user (like .Xauthority), and also unable to access any files
accessible by root (like the /dev nodes).

Is there a kind of changed permission policy in the new linuxulator
that could cause this?  By any chance, would I need to recompile the
linux_base port?

Is anyone using VMWare2 successfully on a recent -current?


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to