To upgrade from xfree-3 to xfree-4 I removed all my installed
ports but I lost mail program (I use XFMail, sorry for this :-)

It compile and install fine but crashes with this message:
The application crashed due to fatal error
All unfinished messages were saved
_: Report the bug with all the relevant information
using the "Bug report" facility
Missing or failed fl_initialize()--Invalid argument

I tryed demos from xform and they works, so I examied source of
xfmail and discovered that is use, seems that xforms
crashes with original and works with

I installed compat3x from ports and recompiled world three times
(sigh) also with recent cvsup (last update this morning, GMT+1)
with COMPAT3X=yes and COMPAT4X=yes in /etc/make.conf but it crashes
the same.  Finally I tryed this (HACK?) and it works for me.

-----8<-----[ before ]-----8<-----
# ldconfig -r | grep
        33:-lc.5 => /usr/lib/
        67:-lc.3 => /usr/lib/compat/
        89:-lc.4 => /usr/lib/compat/

-----8<-----[ hack ]-----8<-----
# cd /usr/lib
# mv compat/ compat/
# ln -s

-----8<-----[ after ]-----8<-----
# ldconfig -r | grep
        33:-lc.5 => /usr/lib/
        66:-lc.3 => /usr/lib/
        89:-lc.4 => /usr/lib/compat/

And now XFMail works  :-)  This is my first message after a week
of blackout...


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to