At Sun, 18 Nov 2001 09:37:12 +0100 (MET),
Hellmuth Michaelis wrote:
> 
> Thought i update my current this morning and ran into two problem with
> vmware:
> 
> 1) when starting vmware, vmware.sh aborts with
> 
>    vmware.sh: cannot create /compat/linux/dev/vmnet1: no such device
>    or address

Hi Hellmuth,

that can be fixed with using /dev/vmnet1 instead of the /compat device
in /usr/local/etc/rc.d/vmware.sh.  I needed this change since about
two months now, IIRC.

Since about two weeks this no longer enough, however.  I now get
"Could not open /dev/vmnet1: Device not configured" when I start
VMWare2.

I also tried to update /compat/linux/dev/vmnet1 to match the
/dev/vmnet1, and that got me just a litte bit farther.  I now get
"Could not get address for /dev/vmnet1: Invalid argument
Failed to configure ethernet0." I added some printf's to
linux_ioctl.c, and it seems the linux_ioctl_socket() gets a device
name which is "", i.e. the empty string.

I am clueless as to where to go next.

> 
> 2) after that i tried to recompile/reinstall the vmware2 port and ran into
> 
>    /usr/ports/emulators/vmware2/work/vmware-distrib/vmmon-only/freebsd/ \
>    hostif.c:177: invalid type argument of `unary *'

I didn't get that error, and I am also building from source.  Did you
CVSUP recently?  My VMWare2 Makefile is version 1.41, dated.
2001/11/11 08:36:28.

-- 
Gre,
Georg.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to