Mathieu Arnold wrote:
> Warner Losh wrote:
> > 
> > 4.4-r -> current build is very broken right now.  I'll investigate and
> > fix.
> last time I did it, I had a problem with install, adding LDFLAGS+=  
> -static to src/usr.bin/xinstall/Makefile fixed the problem.
> the problem was using install linked to to do something like
> this :
> rm
> install
> which was failing for obvious reasons :)

I think this will fix it:

I would have liked to change the 'beforeinstall' to 'afterinstall' in, but afterinstall seems to not be usable.  Another option is
RCS file: /home/ncvs/src/lib/compat/,v
retrieving revision 1.8
diff -u -r1.8
---        22 Sep 2001 08:11:24 -0000      1.8
+++        8 Dec 2001 21:04:42 -0000
@@ -3,7 +3,7 @@
 LIBCOMPATDIR?= ${LIBDIR}/compat/aout
 .if defined(LIBS) && !empty(LIBS)
-beforeinstall: __remove-stale-libs
+maninstall:: __remove-stale-libs
 __remove-stale-libs: .PHONY
 .for lib in ${LIBS}
 .if exists(${DESTDIR}${SHLIBDIR}/${lib})

.. but if there was ever any abuse of bsd.*.mk in our tree, this would be
it.  It hooks onto the manpage install hook so that it can remove the
old libraries *after* the compat libraries are installed.

I think the first one is cleaner though.  It moves the 4.x libraries to /
usr/lib/compat first, then attempts to install new ones over the top. If
something goes wrong trying to install the new ones, at least the old
libraries will still be in /usr/lib/compat.

"All of this is for nothing if we don't go to the stars" - JMS/B5

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to