Hello everybody,
I'm getting a lock order reversal from pcm over last days,
which look like this:

Dec 15 16:47:54 mephisto kernel: lock order reversal
Dec 15 16:47:54 mephisto kernel: 1st 0xc390e640 pcm0 @ 
Dec 15 16:47:54 mephisto kernel: 2nd 0xc390e500 pcm0:play:0 @ 

I don't know if this is important, but I also get complete freezes of my box somtimes
and I don't know if there is a connection between this two things

Here are some additional information:
# cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <Creative EMU10K1> at io 0xdf80 irq 9 (4p/2r/0v channels duplex default)
# uname -a
FreeBSD mephisto.cthulhu.net 5.0-CURRENT FreeBSD 5.0-CURRENT #0: Thu Dec 13 17:48:44 
CET 2001 *cut*

my dmesg ouput is attached.
if this is irrelevant please ignore this mail
and sorry for my bad english, it isn't my native language ...

Christopher Sharp

FreeBSD the Power for Everything !
Christopher Sharp       <[EMAIL PROTECTED]>
Copyright (c) 1992-2001 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #0: Thu Dec 13 17:48:44 CET 2001
    [EMAIL PROTECTED]:/usr/src/sys/i386/compile/KERNEL
Preloaded elf kernel "/boot/kernel/kernel" at 0xc054b000.
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 350798022 Hz
CPU: AMD-K6(tm) 3D processor (350.80-MHz 586-class CPU)
  Origin = "AuthenticAMD"  Id = 0x58c  Stepping = 12
  AMD Features=0x80000800<SYSCALL,3DNow!>
real memory  = 268435456 (262144K bytes)
avail memory = 255389696 (249404K bytes)
K6-family MTRR support enabled (2 registers)
Using $PIR table, 7 entries at 0xc00f7c00
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <AcerLabs M1541 (Aladdin-V) PCI host bridge> at pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci0: <bridge, PCI-unknown> at device 3.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
ahc0: <Adaptec 2940 Ultra SCSI adapter> port 0xdc00-0xdcff mem 0xdffff000-0xdfffffff 
irq 10 at device 14.0 on pci0
aic7880: Ultra Wide Channel A, SCSI Id=7, 16/255 SCBs
atapci0: <AcerLabs Aladdin ATA33 controller> port 0xffa0-0xffaf irq 0 at device 15.0 
on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pcm0: <Creative EMU10K1> port 0xdf80-0xdf9f irq 9 at device 16.0 on pci0
ed0: <NE2000 PCI Ethernet (RealTek 8029)> port 0xdf40-0xdf5f irq 5 at device 18.0 on 
ed0: address 00:50:ba:bc:f0:77, type NE2000 (16 bit) 
ata-: ata0 already exists, skipping it
ata-: ata1 already exists, skipping it
ed-: ed0 already exists, skipping it
sc-: sc0 already exists, skipping it
vga-: vga0 already exists, skipping it
orm0: <Option ROMs> at iomem 0xc0000-0xc9fff,0xcc000-0xcc7ff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
pmtimer0 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources
unknown: <PNP0a03> can't assign resources
unknown: <PNP0501> can't assign resources
unknown: <PNP0501> can't assign resources
unknown: <PNP0700> can't assign resources
unknown: <PNP0f13> can't assign resources
ad0: 28629MB <QUANTUM FIREBALLlct20 30> [58168/16/63] at ata0-master UDMA33
acd0: CDROM <CRD-8320B> at ata1-slave PIO4
Waiting 15 seconds for SCSI devices to settle
Mounting root from ufs:/dev/ad0s2a
cd0 at ahc0 bus 0 target 6 lun 0
cd0: <YAMAHA CRW4416S 1.0h> Removable CD-ROM SCSI-2 device 
cd0: 8.333MB/s transfers (8.333MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed

Reply via email to