* Dan Nelson ([EMAIL PROTECTED]) wrote:
> > I just found out why my mutt MUA segfaulted. It came down to old libs
> > lying around that were still linked with libc4 instead of libc5. Mutt
> > (from mutt-devel port) compiled beautifully, but it segfaulted on
> > startup. Could this be one for the FAQ or something? Maybe explaining
> > library differences between STABLE and CURRENT and you should be
> > extra careful when an app mixes libc4 and libc5?
> Actually, you should have gotten a linker warning about having
> dependencies on multiple versions of a library.  Usually it'll just
> fail to link though.

Well, it didn't fail, and I never saw that linker warning. I spend quite 
some time with a Mutt developer going back and forth, and trying out
different stuff. I decided to build mutt and its dependancies again
which solved the problem. Maybe the linker warning scolled by too fast. 
Well at least my trusty mutt works now :-)

I do have COMPAT4X in my make.conf though... Maybe that had something to
do with it?

"What is wanted is not the will to believe, but the will to find out,
which is the exact opposite."
                -- Bertrand Russell, "Skeptical_Essays", 1928

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to